Red Screen Artifacts When flux is on



  • This post is deleted!


  • Same thing on a Lenovo Thinkbook laptop, with the latest Intel Graphics drivers. The pixels don't appear on a screenshot of a problematic image.

    Windows: 18363.1256 (Windows 10 1909)
    Provider: Intel Corporation
    Version: 27.20.100.9030
    Date: 27/11/2020
    Video Processor: Intel® Iris® Graphics Family
    Device Id: PCI\VEN_8086&DEV_8A52&SUBSYS_385217AA&REV_07\3&11583659&1&10



  • Can anyone say if this is persisting on the 2020 Windows release?

    We will see what we can find out.



  • @herf Yep, same problems with low temps

    Intel Corporation 26.20.100.7463: Intel(R) Iris(R) Plus Graphics (20191106)
    Citrix Systems Inc. 12.40.44.247: Citrix Indirect Display Adapter (20190123)
    NVIDIA 27.21.14.5709: NVIDIA GeForce GTX 1650 Ti with Max-Q Design (20201022)

    Generic PnP Monitor, 294 x 165mm, built 2020
    Chromaticities:
    R=0.639648 0.329102
    G=0.299805 0.599609
    B=0.149414 0.059570
    W=0.312500 0.328125
    sRGB gamut: 99%, AdobeRGB gamut: 64%

    Winlimit=0, 1
    Monitor 1 on Intel(R) Iris(R) Plus Graphics: VCGT=1 gamma=1

    Windows Build: 18363.1256



  • I've been having a similar, awful problem. Has there been any progress on this?

    I LOVE f.lux! I've been using it for years, and I can't figure out what started this or how to fix it. The only solution seems to be to stop using flux entirely.

    It only happens on one monitor (primary). I'm using the latest version of Windows 10, with Intel HD graphics. My guess is that for whatever reason, certain dark greys are overflowing to bright, fluorescent blue.

    Example picture

    Here's my driver info:

    Intel Corporation 27.20.100.9168: Intel(R) UHD Graphics 630 (20210108)
    NVIDIA 27.21.14.6140: NVIDIA GeForce GTX 1650 (20210122)

    Dell AW3420DW(DisplayPort), 798 x 335mm, built 2020
    Chromaticities:
    R=0.639648 0.330078
    G=0.299805 0.599609
    B=0.150391 0.059570
    W=0.312500 0.329102
    sRGB gamut: 100%, AdobeRGB gamut: 64%

    Dell SHP14B9 Display, 344 x 194mm, built 2019
    Chromaticities:
    R=0.681641 0.318359
    G=0.190430 0.800781
    B=0.099609 0.020508
    W=0.320313 0.334961
    sRGB gamut: 102%, AdobeRGB gamut: 100%

    Winlimit=0, 0
    Monitor 1 on Intel(R) UHD Graphics 630: VCGT=1 gamma=1
    Monitor 2 on Intel(R) UHD Graphics 630: VCGT=1 gamma=1

    Windows Build: 19042.746

    Thanks all.



  • @Benjamest Any progress on your issue?



  • Hi @kiloblaster - that is a blistering ton of OLED gamut. Is the problem happening on both displays (or otherwise, with the second one unplugged?)

    Can you try turning off f.lux options > "Use display data for better color accuracy" to see what happens? The colors should be extreme (more saturated).

    I wonder if we're conflicting with some new systems in Windows 10 for these wide-gamut displays...



  • @herf it happens only on my monitor, not my laptop display (it's a laptop). Disabling the laptop display doesn't seem to do anything. Toggling whether to use display data for color accuracy did seem to make it worse last night, with my dark grey taskbar turning bright blue. I can get you some screenshots later today, but I wanted to reply to this early as possible.

    Thanks for your really fast reply! I didn't even think to check before bed last night.



  • Also, both of your monitors seem to have color profiles - can you email them to support at justgetflux.com?

    I am trying to figure out if something's going on with newer graphics drivers, or if it's something related to the latest Windows update.



  • @herf you're not gonna believe this. I just sent you my color profiles that were causing issues. To do that, I had to find the directory storing the ICC color profiles. I found some that were old and not added to the system - so for fun, I just installed one of those profiles, and switched to it, and then switched back to one of the old profiles. They're close to the same.

    Then I started f.lux to see the issue again.

    The issue resolved itself.

    I had switched between installed color profiles with no effect. So I think it was INSTALLING a color profile that solved this issue, at least temporarily (it's only been about 5 minutes).

    What the heck!



  • @herf Aaaaand the problem is back. I didn't change anything from last night. I'm frustrated and at a loss.



  • I have a few ideas - will move to email.



  • We found a problem with invalid color profiles and fixed it in v4.119. This should affect a tiny number of users.



  • @herf v 4.119 did not fix it for me. Let me know if I can provide any extra information.



  • @herf just signed up to let you know I also still have this problem when set darker than 3300k.

    Running 4.119, Win 10 x64, Lenovo Flex 5.



  • @Mathieu And for what it's worth, I upgraded Windows 10 from 1909 to 20H2, but it doesn't fix the bug either, still with f.lux 4.119 / latest Intel drivers.



  • Sent some emails to people for followup...



  • Hi,

    I use flux from a long time. It's a good software. But, I have the same problem with my news laptop Lenovo Idepad with Intel iris graphic.

    I had before another lenovo ideapad not being on intel iris is I did not have this problem ...

    My windows i'ts a clean install (not pre-installed windows). All my driver are up to date. Windows 10 20H2.

    I hope this problem can be corrected ...

    PS: Sorry for my little English.

    Thanks for your job !



  • Same thing happening to me. Brand new XPS13, have used F.lux for years. But only happening on movie mode!!



  • I have the same problem - is there a known solution?

    ![0_1622128602206_Screenshot 2021-05-27 111432.png](Uploading 100%) ![0_1622128612512_Screenshot 2021-05-27 111432.png](Uploading 100%)



  • Thanks - there are apparently issues with the new Intel GPUs, and I guess we are first to hear about it.

    Can you post f.lux options > driver info here and we'll try to forward to the right people?



  • @herf

    Intel Corporation 27.20.100.9320: Intel(R) Iris(R) Xe Graphics (20210407)

    Wide viewing angle & High density FlexView Display 3840x2400, 302 x 188mm, built 2020
    Chromaticities:
    R=0.680664 0.315430
    G=0.259766 0.684570
    B=0.146484 0.055664
    W=0.312500 0.328125
    sRGB gamut: 100%, AdobeRGB gamut: 85%

    Generic PnP Monitor, 597 x 336mm, built 2015
    Chromaticities:
    R=0.661133 0.332031
    G=0.301758 0.613281
    B=0.149414 0.059570
    W=0.313477 0.329102
    sRGB gamut: 100%, AdobeRGB gamut: 69%

    Winlimit=0, 1
    Monitor 1 on Intel(R) Iris(R) Xe Graphics: VCGT=0 gamma=1

    Windows Build: 19042.985



  • I am getting the pink artifacts on my new Intel NUC. Driver info:

    Intel Corporation 27.20.100.8935: Intel(R) Iris(R) Xe Graphics (20201028)

    Winlimit=0, 1
    Monitor 1 on Intel(R) Iris(R) Xe Graphics: VCGT=0 gamma=1

    Windows Build: 21390.1



  • @herf Just wondering if there is a known solution?



  • This thread is getting long - we have fixed several issues up above.

    What I think is remaining is the Intel Xe color artifacts, so two things:

    1. Can anyone post a photo of the screen?
    2. Can you install the "Intel Graphics Command Center" (Windows Store) and see if the color settings tell us anything?

Log in to reply