Feature request: I'm up!



  • It happens sometimes that I get up very early, but after sunrise. At this point f.lux still has my computer in bedtime colors, but I want daytime colors. I can get by with "Disable for an hour" but it's a bit annoying that I have to click it every hour. "Disable until sunrise" doesn't work for me because it's after sunrise, so if I choose it I won't get warm colors later that day.

    I would like an "I'm up" feature which make f.lux act as if right now were my wake time. Alternately a "Disable until sunset" feature would work for me, too, if that did not stop the normal transition into nighttime colors.

    It would also be helpful if you popped up a warning when choosing "Disable until sunrise" when it is between sunrise and the start of the transition into sunset color and the screen is not showing daylight colors. (In other words, between sunrise and the end of the sunrise and wake-up transitions to full daytime color.) The warning would be that it's after sunrise ("sunrise was 10 minutes ago") so f.lux would be disabled for X hours, maybe you just want to use "I'm up" instead.



  • I have the same problem with waking up early. It would work better for me if there was an option to always go to daytime mode at sunrise.



  • I have the same issue sometimes, and I'd like to have this feature too.


  • f.lux team

    We have pages of sketches about this! It gets pretty hard when you consider night-shift work and a bunch of other cases, but I agree if you usually get up well after sunrise, we should do something different.

    There is also a case for the person who always wakes up before sunrise, and another who does it only sometimes.

    We adjusted the AM transition in the new build to help this case somewhat...so within a half hour of your normal wake time the screen should be very close to white.

    If you're curious, we also debate the circadian impact for extreme early birds: since your computer screen is bright enough to shift your sleep schedule, then what f.lux should do before the sun rises is to make your screen less stimulating, because you don't want to get up even earlier the next day.

    But I agree, if the sun is already up, the screen doesn't matter so much in comparison, and should mostly be white.



  • @herf I agree there can be some pretty complicated use cases. What to do about people who normally get up before sunset is quite interesting. There is a lot to consider.

    However, I've thought about it more and I believe my request and use case is quite straightforward. Between sunrise and sunset "Disable until sunrise" should change to "Disable until sunset". The use case is "f.lux is messing with my screen colors and as far as I'm concerned, it should be off, but it should automatically come back on at the next sunset." In fact, since f.lux is typically off during the day anyway, if there were only one option is should be "disable until sunset" since that would be functionally equivalent to "disable until sunrise". I grant, however, that the wording might confuse users, so I propose having the wording change anyway.


  • f.lux team

    Yes I think about night-shift workers too much.

    There is a solution for this, and I will fix it. :)



  • A work-around for this could be to automatically quit f.lux at 5am or so, and start it up again at noon. That can be done in the terminal with launchctl, but it's a little complicated. Maybe there's a nice user interface app for that?



  • There's an old free version of "Lingon" which seems to still work, at least for this:
    Lingon - Browse /Lingon/2.1.1 at SourceForge.net

    You could create two Agents, one to quit f.lux around sunrise, and one to start it again around noon. The commands you need are:
    killall Flux
    and
    open -a Flux



  • @herf any news on this? I have this issue multiple times a week:

    • get up before my defined wake up time
    • press "Disable until Sunrise" to make my screen normal
    • forget to enable flux again at sunset

    A simple "Disable until Wake up time" or "Disable until Sunset" feature would fix this.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.