f.lux issue with screensaver on macOS



  • Hello, I’m using screensavers to boost my creative thinking and get a quick break. Flux, however, also seems to be taking a break: Each time I exit the screensaver (e.g. by hitting a key) at night, Flux is turned off. Only after a second or so does it dim the screen colours again. This ”flash of daylight” is hurting my eyes. Anything you can do to make Flux run all the time, even with Mac OS screensavers?

    macOS and f.lux are both up to date.



  • @Ecke77 Have you tried to check and use ”Fast transitions” under Options?



  • yes and it doesnt help


  • f.lux team

    Which screen saver are you seeing this with? can you tell me more about your machine?



  • I am using a default screensaver from macOS and my machine is MacBook Air (middle 2012).


  • f.lux team

    We backed off how often we look for changes from other apps. It used to be twice a second, and now it is once a second.

    So this means we use less CPU in the background, and you get an extra 0.5 second flash. Ugh!



  • @Ecke77 I have the same problem with you.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.