Flux is already running



  • Hi,

    I'm a programmer student in a school with about one thousand computers, all on Mac OS X. Our system administrators do play a lot with the network. Sometimes f.lux works, sometimes not, and they don't want to spend time on finding out why.

    It's been 3 weeks we have not f.lux because we get the error message "Flux is already running", but it isn't running at all.

    When I launch flux from console, I get the following message :
    $ ./Flux
    2016-03-11 14:06:00.118 Flux[57743:660657] Failed to connect (prefsMenu) outlet from (FluxMenulet) to (NSWindow): missing setter or instance variable

    We are not root.

    My /tmp does not contain anything with "flux" in it's name.

    Can you please help us ?
    Thanks in advance



  • @Bilow Sometimes the "only one copy of Flux can be running" error can be fixed by doing this:

    • in the Finder, press command-shift-G.
    • type or paste this into the box: ~/Library/Application Support
    • look for a folder called Flux, if it's there, put it in the trash.
    • press command-shift-G again.
    • type or paste this into the box: ~/Library/Containers
    • look for a folder called com.justgetflux.flux, if it's there, put it in the trash.
    • empty the trash.
    • start Flux.


  • @Elhem-Enohpi

    Just deleting those two folders didn't solve the problem. But when I move them to /tmp, and I make symbolic links from the Library directories to them, it works !

    Thanks a lot !



  • What happens when you move those 2 folders to any other folder or Desktop?

    You may need to check permissions in those folders and making sure you as user have full access. Had the same issue when noticed in the "Containers" I had no access. Fixed that and now Flux starts.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.