"only one copy of f.lux can be running at any time" error



  • i realize someone else has posted about this before, but there was no resolution on the subject, and i think i may have a little more information to share than the last post.

    I had my logic board and top case replace by Apple in November of 2015 and a SSD installed in January. Since then some random apps have not been very happy and are asking for permissions.

    After the installation of the SSD is when i began having issues with f.lux.

    I uninstalled the app, redownloaded and installed again and continue to see the "only one copy of f.lux can be running at any time" error.



  • @Caleb-Denman go to the "applications" folder or do a search and delete all f.lux files.

    Also go to activity monitor and stop the f.lux program. Also are you using the icon by the clock to exit f.lux?



  • @Tungsten_smooth there isn't anything in the applications folder related to f.lux. it does not appear in the menu bar, nor does it show up in the activity monitor or in terminal using the "top" command.



  • @Caleb-Denman Just try reopening the zip folder (which I guess installs it, I wish windows did that!)



  • @Tungsten_smooth yeah that doesn't work either. i re-downloaded from the site to make sure i had a current version, and am still seeing the same error


  • f.lux team

    Check out System Preferences > Users and Groups > Login Items

    You should have just one "f.lux" and can remove the rest. We try to do this for you but sometimes we miss.



  • @herf this didn't help either unfortunately :/


  • f.lux team

    @Caleb-Denman How frustrating. Is there any chance you have two running in Activity Monitor? search for "Flux" with no dot. Has a reboot helped / changed anything at all?



  • @Caleb-Denman It sounds like a permissions problem with the lockfile. Try this:

    • in the Finder, press command-shift-G.
    • type or paste this into the box: ~/Library/Application Support
    • look for a folder called Flux, if it's there, put it in the trash.
    • press command-shift-G again.
    • type or paste this into the box: ~/Library/Containers
    • look for a folder called com.justgetflux.flux, if it's there, put it in the trash.
    • empty the trash.
    • start Flux.

    I think whoever installed your SSD didn't do a very good job when transferring the files over, and you've ended up with some of them belonging to a different user ID than your own. If your whole Library folder doesn't belong to you, then the above might not work - and a lot of other things too. You may need some help getting it fixed up.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.