Mouse cursor flicker from pointer to loading constantly



  • Has anyone figured out how to solve the constant flicker of the cursor? Upon install, the mouse flickers between the standard pointer to the circle loading icon. I tried previous fixes that were on different version but no luck. I could not install as admin, but will see if my company allows if that is the suggested fix.



  • Can you post your driver info? f.lux options >driver info.

    Long ago, we knew of some drivers that would hook color changes, but it is not a good idea.



  • Here it is. I am not sure i explained what is happening accurately. I do have two different monitors as well. Laptop screen is closed.

    Intel Corporation 27.20.100.8935: Intel(R) UHD Graphics (20201028)

    Generic PnP Monitor, 598 x 336mm, built 2021
    Chromaticities:
    R=0.666992 0.324219
    G=0.309570 0.614258
    B=0.144531 0.064453
    W=0.313477 0.329102
    sRGB gamut: 99%, AdobeRGB gamut: 68%

    Generic PnP Monitor, 597 x 336mm, built 2021
    Chromaticities:
    R=0.685547 0.308594
    G=0.264648 0.667969
    B=0.150391 0.057617
    W=0.313477 0.329102
    sRGB gamut: 101%, AdobeRGB gamut: 83%

    Unlimited gamma ramp=1, Internal ramp=1
    Monitor 1 on Intel(R) UHD Graphics
    Has VCGT profile=0, Gamma Ramp works=1
    Monitor 2 on Intel(R) UHD Graphics
    Has VCGT profile=0, Gamma Ramp works=1

    Windows Build: 19042.1165



  • @herf Do you know of a solution? I may have to get rid of the application for now until there is a resolution.



  • A couple things:

    1. There are 2021 versions of the Intel drivers - that would be the first place to look
    2. f.lux tries to avoid using the "internal" color settings in Windows - so if you look in the Color menu you should be able to expand the range of the standard one and use that instead.

    https://www.intel.com/content/www/us/en/download-center/home.html



  • @herf My company laptop so i cannot modify the driver but they appear to be 2020 as the date of the latest driver. I tried the color setting as you mentioned but still get the flickering mouse. When I disable f.lux, it is still happening. Any other suggestion or should I see about getting the drivers updated first?



  • Drivers can make extra changes when you adjust settings - they probably should not! But presumably there is some "Intel" related user interface software that updates when we make adjustments. I am not seeing anything like this in the newer drivers.

    Here are some things to look for:

    1. Can you run a "performance test" within f.lux to see how slow this is?
    2. Can you get to an "Intel Control Panel" or "Intel Command Center" or any of these? You may be able to turn on or off some settings there
    3. You could also run task manager (sort "details" by "CPU") and see if anything pops up when you move the sliders around in f.lux


  • Here are the details from the performance test. Could not upload a photo successfully or screenshot.
    Average: 59.1 FPS. Worst = 29.4 FPS. Missed 60Hz: 1% Missed 30Hz: 0%

    I have access to a Intel Command Center setting console. What are the settings I should be looking to disable if any?



  • @levas002 I am not sure - was there any Intel control panel like that running in your tray before? You could check task manager > startup and try to exclude it.

    What I expect is happening is that there is some interface in Windows that is listening to color changes and redrawing every time things change. Since there is no way to do this directly through Windows, in most cases it is part of the driver software.



  • Here is what is an intel process running in the background currently. Which would be the one to disable?

    fm igfxCUIService Module 0% 0.4 MB
    igfxEM Module 0% 2.4 MB
    [HI igfxext Module 0% 0.4 MB
    Hm Intel HD Graphics Drivers for Windows(R) 0% 0.4 MB
    dU Intel(R) Capability Licensing Service TCP IP Interface 0% 0.3 MB
    m Intel(R) Dynamic Application Loader Host Interface 0% 0.2 MB
    T Intel(R) Dynamic Tuning Service 0% 0.3 MB
    [ID Intel(R) Local Management Service 0% 3.6 MB
    1 Intel® Graphics Command Center 0% 58.1 MB
    rm Intel® Graphics Command Center Service 0% 11.6 MB
    rm Intel® SGX Application Enclave Services Manager 0% 0.8 MB
    [HI IntelAudioService 0% 2.8 MB
    [H IntelCpHeciSvc Executable 0% 0.3 MB



  • @herf Based on the last reply, which do you recommend disabling?



  • I would do these things:

    1. Look in the tray for any obvious "intel graphics" interfaces
    2. Right click on the desktop and do the same
    3. My best guess is to stop the "Command Center" processes first, and
    4. then the CUIService

    but am only making guesses. You can try these things and worst-case you'll have to reboot.

    I think ultimately the right solution still is to update the drivers.



  • Thank you. I will have to try the driver updates by submitting a service ticket. I can't even end those processes without administrative access.


Log in to reply