f.lux interfering with Windows 10 brightness hotkeys - Dell XPS 13 9370



  • I have been having issues with changing my system brightness using the built in hotkeys on my Dell XPS 13 9370, after disabling f.lux from running on startup the issue seems to be gone. But as soon as I return f.lux to running startup it returns. I've also tried rolling back my graphics driver, to no avail.

    Intel Corporation 26.20.100.7263: Intel(R) UHD Graphics 620 (20190925)

    Generic PnP Monitor, 294 x 165mm, built 2017
    Chromaticities:
    R=0.639648 0.329102
    G=0.299805 0.599609
    B=0.149414 0.059570
    W=0.312500 0.328125
    sRGB gamut: 99%, AdobeRGB gamut: 64%

    Monitor 1 on Intel(R) UHD Graphics 620: VCGT=0 gamma=1

    Windows Build: 18362.592



  • Usually the brightness keys should control the backlight and not interfere, but it sounds like they are doing something else.

    You can try right-clicking on the desktop and choose "Intel Graphics Settings". Look in Power and see if any of the settings there make a difference. (Personally I always turn off dpst because I don't like how it looks).

    There is also a slightly newer driver for the Intel 620, not sure if that would help or not:
    https://downloadcenter.intel.com/product/96551/Intel-HD-Graphics-620