Usually the brightness keys should control the backlight and not interfere, but it sounds like they are doing something else. You can try right-clicking on the desktop and choose "Intel Graphics Settings". Look in Power and see if any of the settings there make a difference. (Personally I always turn off dpst because I don't like how it looks). There is also a slightly newer driver for the Intel 620, not sure if that would help or not: https://downloadcenter.intel.com/product/96551/Intel-HD-Graphics-620