Windows 10 May update (1903)



  • Problems with the Windows 10 May update (1903) are related to "Fast Startup"

    Here is what we know:

    • If you shutdown/startup (with fast startup enabled) Windows color will fail - color profiles will not load, and f.lux will use its "fallback mode"
    • A simple reboot makes things work again
    • Starting up with "fast startup" disabled works also

    If you shutdown and restart your computer and don't want to do the extra reboot, you can disable Fast Startup using these steps:

    1. Go to Power and Sleep settings
    2. Choose "Additional power settings" to get to the old Power Options control panel
    3. From the Power Options control panel, choose "Change what the power button does"
    4. You should now be in "Power Options > System settings"
    5. Click "Change settings that are currently unavailable"
    6. Uncheck "Turn on fast startup"
    7. Restart

    Notes on 1903

    We shipped 4.104 to handle some problems in the Windows 10 May update, also called the 1903 update.

    I'll make notes here as I learn more:

    • Tinted screenshots. This is apparently due to a problem with display mode changes that disables the normal color system we use in Windows, and it is a sign that f.lux is working around the bug. We expect a future Windows build will fix this. We know that other features that use color profiles are not working at all in this case.
    • Dimming hotkeys don't work: This is a sign of the same thing happening. If it keeps up we can probably make a workaround.

    Fix has not yet appeared as of 18362.175



  • The dimming functionnality is also not working. Could anyone please confirm this as i'm a fan of this feature?



  • This is another symptom of the color system having failed in Windows. It is not dimming in our "workaround" mode (which it did before) but it works properly after a reboot.



  • I can confirm that. I shut down my PC every evening, and I had this problem for 3 days consecutively, but it started working again today. Not sure if it's been updated in the background or if it was completely bad luck, but it works now. Thanks!



  • I can report that i've also got tinted screenshots, and 4.104 with 18362.116.

    I guess i just have to wait until 18362.145. Until then i'm running f.lux disabled,
    since i run screen-capture software that needs to accurately know correct colors.

    It was nice how it worked before, surely a great feat of engineering :)



  • These both of symptoms are there in my newly updated windows, a solution would be very helpful,
    and one more thing that every administrator permission asking prompt page is appearing untinted whether f.lux is turned on or not.



  • @herf

    "18362.145 (KB4497935)" is installed and the tinted screenshots still exist. Everything works fine after restart Windows.



  • Anyone who still has this problem after the .145 update (@darksapex) please post f.lux options > driver info so we can investigate.



  • 0_1559511042605_5237fc0b-be4a-4e7d-adb6-7facee3700e5-image.png

    Hey guys, I'm using ShareX to take a screenshot and video/gif and more and after Windows May update, I have this problem when I taking a screenshot (look at the photo)
    if I restart my PC the problem fixed but after while she coming back
    I try to reinstall F.lux or ShareX, still have this problem
    any fix for this?



  • Can you check using these steps?

    1. After reboot, when things are OK, change display resolution
    2. Does it fail right away after this?


  • @herf 0_1559556621211_screen.JPG
    I'll try those steps later and inform you.



  • The option to disable for fullscreen apps is not working at all for me on both screens. I can disable manually fine or use the shortcut 'alt + end', but if I select to disable for fullscreen apps it does not work since the Windows 10 May update. I am on 4.104.



  • @cymatics yes this is a bug in the fallback mode - it is trying to disable for one monitor and failing. we can make it disable for both in the future. But again, we shouldn't be in fallback mode at all.



  • @herf said in Windows 10 May update (1903):

    Can you check using these steps?

    1. After reboot, when things are OK, change display resolution
    2. Does it fail right away after this?

    no, after while it coming back or after game... god I hate this



  • @makaveli So would you say games are knocking it out?



  • I also have issue with tinted screenshots. I have this issue after turn off and turn on PC from menu start everything. When I reboot PC, then I don't have this bug.

    I also have issue with v3 version on latest Windows. When I turn off and turn on PC from menu start blue light filter completly don't work. I need to reboot PC to make it work again.

    https://forum.justgetflux.com/topic/7033/problem-with-latest-windows-1903



  • @locarno Can you also post f.lux options > driver info?

    We are trying to understand if this is due to a particular vendor or to Windows itself.



  • @herf sometime just by browsing the web.
    I blame windows update..



  • Our 4.105 beta (only the beta users) will now send color system failures and driver versions as part of the update.

    Right now I have no idea how many people this is affecting, though it seems to be quite a few.

    If you want to help out get on our beta (about box to change it).



  • Thank you for all the feedback - the beta is reporting that about 33% of machines are failing, which is incredibly high. We are reporting this to Microsoft and will see what they can do.



  • Apparently the dimming functionnality is very buggy. I thought it was just a coincidential bug at first, but it persists. I really don't know what causes it, maybe when the monitor turns itself off after what i set it to (http://prntscr.com/nxns3a) but it keeps doing it. I can just never dim my screen when it's too bright at evening, literally the most useful feature i use in f.lux personnally :( Hope this gets fixed too!



  • @herf I installed clear copy of Windows 1903 and latest nvidia driver.

    If you need I can record video from this 2 bugs. It is strange that after reboot eveyrthing is ok but after turn off and turn on it don't work.

    You think Microsoft will fix this ? You can't fix this by flux update ?

    alt text



  • @locarno tell me exactly what you mean by "turn off and turn on"? like a full system reboot?



  • All was working perfectly and after update I have following problems:

    • disable for fullscreen apps doesn't work anymore

    • mouse cursor is always cold

    • can't disable for one monitor

    0_1559767825142_flux.png
    ...oh and apparently I have that screenshot problem too :]

    PS I'm on 4.104 and can't see the Beta switch in about window...



  • I guess it must be that stupid Windows Update that caused the issue as I didn't do anything unusual and now when I play games such as (Hunt Showdown), I don't notice anything unusual at daytime maps but if I play on night maps, the darkness is like 3-4x darker to a point it is completely unplayable! Things that happened about at the same time:

    • Game went from v6.0 to 6.1 but nothing that's suppose to cause this and I'm the only person who got affected.
    • I updated last month driver to the latest Nvidia driver, no reason why it would cause this.
    • I thought it was because I created a ICC profile with my (ColorMunki Display) at V4 rather than V2 even though I always been in V4. I made a new one in V2 and it seemed to have fixed the darkness issue.

    After all no longer than 1 day later the same issue happened again even with a V2. I had to revert to the standard sRGB profile from Windows 10 but I ain't sure if it fixed the issue. I have (Disabled for Fullscreen Application) and weither I manually do ALT+End while playing doesn't cause a change. I think I've tried already shutting down Flux while already in-game but I don't remember, I'll have to check but I wouldn't be surprised if the game needs to be relaunched for the change to happen.

    Anyway I also have ANOTHER issue too. I have in the advanced windows color settings, the checkbox enabled for "Reload actual calibration profile" but when I manually click the button it loads my custom profile from the X-Rite, only for 0.5sec then it reverts to the sRGB even if my custom one is set to default and that I have no other profile listed under that monitor, like wtf?! I have no idea why it won't apply AND stay enabled permanently, that is super annoying.



  • @rutra80 I also have the cold mouse cursor, even with software cursor enabled.



  • Hello! I just made a post on the main issue with screenshots and just saw this. Here is my Driver info, if you'd need it to help development.0_1559956613826_f0943112-2098-4d2e-b470-cf6b658eaf71-image.png



  • Here I am too. The most useful feature on f.lux, dimming my screens, is not working. Probably is the latest update of Windows 10 1903. Did you find any workaround?



  • Said enough times but fullscreen disable feature does not work anymore. in no way.



  • Two things we need if you are having problems:

    1. Are you are running 18362.145 (or an older version)? There are fixes in 145 - f.lux beta shows this in options > driver info and otherwise you can use "About my PC" to see this number
    2. Are you running any particular games that trigger this, or do you notice any reboot/sleep activity that causes the problem?

    Our test machine is using this driver:

    Intel Corporation 26.20.100.6891: Intel(R) HD Graphics 620 (20190517)
    Windows Build: 18362.145

    We have run through all the passmark benchmarks to exercise DX9-12, have rebooted/slept, and are not seeing the problem on this configuration. So I need your help to figure out why it's happening.



  • After update to .175 things look good again :D



  • This post is deleted!


  • Just chiming in; I also updated to 18362.175, and it is fixed for me also.



  • In case this link gets lost: "disable when using fullscreen apps" is broken under Windows 10 1903 (18362.145), Flux v4.104. It was working in Windows 10 1809.



  • after the new update, workkkkkkkk great!



  • Ok so today problems came back and I think I know when - after full system restart everything is ok, but then when you have Fast Startup power option enabled and you shutdown and startup the system, things are borked again. So, it seems like something is wrong with kernel modules being woken up after hibernation, which is what happens when one has Fast Startup power option enabled (which is a default system setting) - only user mode and services get shutdown but the kernel gets hibernated.



  • @rutra80 thank you thank you thank you. This is 100% right.



  • I have posted an update at the top of this thread, with instructions for disabling fast startup if you want to:
    https://forum.justgetflux.com/topic/7021/windows-10-may-update-1903



  • @herf yeah, that's what I told you here https://forum.justgetflux.com/post/21601 maybe my english is so bad that I couldn't clarify the exact reason xD

    I really hope you can fix this problem, I only have a HDD and the fast startup helps me.



  • @darksapex yes this is what I get for never shutting down my computer. (Hopefully Microsoft will have a fix soon.)



  • ah shit.. the problem came back.. goddammmit Microsoft



  • hi, I am a long time user of f.lux and decided to register in this forum.
    what I have found is that on fast startup enabled it is broken (dimming function). But you can simply fix this by signing out (user) and signing in again. No need to restart fully



  • Hi,

    I use a laptop with 2 identical external displays. Ever since the 1903 Win10 update, my primary external monitor has been working fine with f.lux for dimming. My laptop display also has been working fine. However, my other external display does not respond to f.lux dimming.

    I tried to disable fast boot, but that did not fix the problem. I am on beta version 4.105.

    I have attached my driver info:

    0_1560553742106_8194a4e7-9a3f-4046-9e4f-d6efa049ca41-image.png

    Rajiv Varma



  • @rajivvarma I would definitely look for a newer DisplayLink driver and possibly enable the gamma ramp registry feature.



  • @herf said in Windows 10 May update (1903):

    @locarno tell me exactly what you mean by "turn off and turn on"? like a full system reboot?

    @rutra80 already explained this.

    @rutra80 said in Windows 10 May update (1903):

    Ok so today problems came back and I think I know when - after full system restart everything is ok, but then when you have Fast Startup power option enabled and you shutdown and startup the system, things are borked again. So, it seems like something is wrong with kernel modules being woken up after hibernation, which is what happens when one has Fast Startup power option enabled (which is a default system setting) - only user mode and services get shutdown but the kernel gets hibernated.





  • What is fallback mode in f.lux ?

    I have f.lux 4.104. It is good version ?

    When Microsoft fix kernel or something ? They even know about this problem ?



  • MS seems to be working on it, yes.

    f.lux uses the GPU in fallback mode, which is why screenshots are tinted. This code path was in there for DisplayLink monitors and it worked automatically for this Windows bug.



  • @herf Seems like my USB3.0 -> HDMI adapter might be the cause of my Win10 problems. I'm gonna try some different adapters from work and see if they make a difference. I also updated to the latest DisplayLink drivers, thanks for the recommendation.

    Rajiv



  • This also happens with a External GPU using the latest Os build.

    NVIDIA 26.21.14.3086: NVIDIA GeForce GTX 750 Ti (20190522)
    Intel Corporation 20.19.15.4531: Intel(R) HD Graphics 4600 (20160929)

    BenQ BL2410, 477 x 268mm, built 2013
    Chromaticities:
    R=0.670898 0.313477
    G=0.266602 0.636719
    B=0.142578 0.080078
    W=0.313477 0.329102

    sRGB gamut: 101%, AdobeRGB gamut: 78%

    BenQ BL2410, 477 x 268mm, built 2013
    Chromaticities:
    R=0.670898 0.313477
    G=0.266602 0.636719
    B=0.142578 0.080078
    W=0.313477 0.329102

    sRGB gamut: 101%, AdobeRGB gamut: 78%

    BenQ BL2410, 477 x 268mm, built 2013
    Chromaticities:
    R=0.670898 0.313477
    G=0.266602 0.636719
    B=0.142578 0.080078
    W=0.313477 0.329102

    sRGB gamut: 101%, AdobeRGB gamut: 78%

    Windows Build: 18362.175


Log in to reply