F.lux stopped working after clearing caches folder



  • Hi there,

    I have a late 2011 13-inch MacBook Pro running macOs High Sierra (10.13.4). While trying to diagnose an issue with my MBP, I cleared the caches folder from ~/library as recommended in this Apple support document.

    F.lux stopped working immediately after. The app itself opens okay, but nothing happens to my screen when I change the light levels. I uninstalled and re-installed with no success.

    Help?

    Thanks



  • Have exactly the same problem...


  • f.lux team

    f.lux doesn't use this folder (aside from updates) - i.e. it shouldn't change how f.lux works.

    I would imagine something else in the system has been affected. Can you try switching color profiles in System Preferences > Displays > Color to see if it helps?



  • Funny you should mention that. Whenever I change my display's color profile in system preferences nothing happens on the screen. It also seems that the changes are not being memorised. This started happening a couple of days ago when I cleaned my caches folder and uninstalled F.lux, and it coincides with the appearance of a very aggressive blue tint on my screen.

    For the blue tint and color profile issues, Apple recommended resetting the SMC and PRAM and if nothing happens servicing my Mac. The resets did nothing and servicing my Mac isn't really an option because Apple considers my machine "obsolete."

    I don't know what to do next. I browsed around but none of the suggested fixes works.


  • f.lux team

    Somewhere in this forum, there is a thread about locked color profiles in 10.13 - basically any "non-display" profile (like the one called "sRGB") seemed to make the color system fail and disallowed switching away from it, which made all kinds of things fail. I recall people worked around it by moving the files away and then back, but I also thought it had been fixed a few months ago.



  • That's very interesting, thanks for mentioning that. I will try to find the posts you're referring to.


  • f.lux team



  • @herf I'm having the same issue as @mfield had in that my display is stuck on sRGB and the corresponding .icc file found at /System/Library/ColorSync/Profiles/sRGB Profile.icc can neither be moved nor deleted.

    Now that I have a better idea of what's going on, I will browse around the web for a solution. I will post here if I find anything.



  • @herf Just to be clear that when I say my display is stuck on sRGB, I mean two things: 1) whichever new color profile I choose, it makes no difference on my screen; 2) my new choice isn't saved so the next time I open system preferences, I still get sRGB.

    To make sure we're all on the same page here, I've uploaded a Safari screenshot to show you what I mean by a "blue tint."

    Is it me or is this blue tint murder to the eyes?

    0_1525029439403_Screen Shot 2018-04-29 at 22.16.06.jpg


  • f.lux team

    In the other thread people thought it had cleared up as of 10.13.3 and 10.13.4. Apparently that's not true.

    I don't have any more knowledge about it, other than this bug seems to break color calibration generally in macOS, and it is not really f.lux-specific (it just affects f.lux because we are the most noticeable color calibration change).



  • Yes I know @herf. Thanks for helping out despite this not being a F.lux-specific issue. I'll contact Apple support again on the off-chance a more knowledgeable technician might have a few useful tricks up their sleeve.

    Will post back here if I hit jackpot.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.