Strange colors/blue-fringed mouse pointer on full-screen YouTube when f.lux is active



  • Me too.
    OSX 10.11.3 (15D21)
    Model Name: MacBook Air
    Model Identifier: MacBookAir6,1
    Processor Name: Intel Core i7
    Processor Speed: 1.7 GHz
    Number of Processors: 1
    Total Number of Cores: 2
    L2 Cache (per Core): 256 KB
    L3 Cache: 4 MB
    Memory: 8 GB
    Boot ROM Version: MBA61.0099.B21
    SMC Version (system): 2.12f143



  • I've got a Mid-2015 13" Retina running 10.11.3, Flux 36.6 with the Intel Iris 6100 doing this exact issue.

    I can reliably reproduce this when running in the default "looks like 1280x800" Retina mode. When I change to the "more space" 1680x1050 mode, the issue goes away (and vice versa) - I guess that's why I haven't noticed it until recently as I usually use the more space mode.



  • Same problem here on a 2015 MBPr with Intel Iris Pro. The problem goes away when I disable automatic graphics switching and use the Nvidia card.



  • Same issue.

    Flux 36.6
    MBA 2014 (hd5000) -- OS X 10.11.5



  • The f.lux team hasn't replied on this topic in 9 months. Is anybody working on fixing this problem?


  • f.lux team

    There is a bug in to Apple, but this is way below us in the system.

    All we can do is recommend you disable f.lux while playing a movie.



  • This happens on a Retina MacBook too (2015) with H5300 graphics, and OS X 10.11.6.

    Has anyone seen this issue in MacOS Sierra too?

    I'm guessing this won't be resolved without Apple's input, and/or if Apple introduce Night Shift on MacOS..



  • Just thought I'd say that this bug is still active with HD graphics 4000 on my mid 2012 macbook pro.

    When I use gfxcardswitcher to force discreet card while using youtube the issue does not appear.



  • Same issue as mentioned by users.

    This issue is while I play fullscreen videos on Youtube, Udacity. Whites are blown out, blue hues here and there, if you move the cursor the problem goes away for a while and then comes back.

    Also this is not just in Safari, it does the same in Chrome too.

    I am running
    f.lux version 37.7
    MacBook Pro (Retina, 13-inch, Late 2013)
    Intel Iris 1536 MB
    OSX version 10.11.6 El Capitan

    This annoying bug has been reported a year ago and it is sad to see that there is no fix yet. I have used F.lux on windows for long and this bug on Mac is kinda making me look for alternatives to F.lux which I really don't want to do.

    Please try to fix this.



  • @shinz4u Agreed, it's a very disappointing lack of action.

    It makes the program completely useless in my opinion. If I have to keep turning it off, it is doing me no good in terms of helping with my body's sleep cycle confusion.

    Flux replies so far have indicated there will be no fix. I'm still following the thread and hoping they sort it out, but it doesn't seem like anybody cares or is working on it. Can anybody recommend a different program? I give up with this.



  • I've gotten around the issue thanks to this little app: Shady for Mac.

    What's a little strange but very good for this specific purpose is that just running the app with the "shade" setting off still fixes the problem. I'm guessing it's doing something similar to gfxcardswitcher in the background, as soon as it's running, so it's probably affecting battery life too (although I haven't paid attention to that myself).

    And of course, turning the thing actually on and reducing the brightness to a minimum ain't bad for your eyes either.



  • This post is deleted!


  • I worked around this by creating a file named safari.css, a text file with these contents:

    .ytp-fullscreen video {
      opacity: 0.996 !important;
    }
    

    Then in Safari preferences > Advanced, you select that file for the Style sheet setting.

    If you want to experiment, every time you edit & save that file, you have to reset the Safari preference back to None Selected and then back to your file.



  • My solution might reduce battery life a bit, hopefully it's not noticeable.



  • You could add Netflix to it if you want:

    .ytp-fullscreen video, #netflix-player.player-cinema-mode video {
      opacity: 0.996 !important;
    }
    


  • @chris-l

    Hi, is there such a preference in chrome for mac that I can change to get a similar solution?

    Thanks a lot



  • @shinz4u Sorry, not sure about Chrome. There are probably extensions available that let you add your own CSS rules, but I haven't looked into it. I might publish my own extensions to make it easier for everyone.

    I actually am not using f.lux at the moment, but I calibrated my laptop display with a lower color temperature than normal, and it has the same bug that you get with f.lux -- videos have artifacts in the brightest parts, but only when they are full screen with nothing else composited on top of them. Maybe the video driver uses an optimization for this case that doesn't quite work.



  • @shinz4u I just figured it out in Chrome. Thanks @chris-l for the fix! This thing was driving me nuts.

    Quick guide for web devs: Just add opacity: 0.996 !important; to the HTML5 video element in Chrome's developer tools.

    Detailed steps for non web devs:

    1. Open a tab with the Netflix video you want to watch (haven't tried with YouTube, but same principle should apply).
    2. Open Developer Tools by going to View > Developer > Developer Tools (or by hitting alt+cmd+i).
    3. Click the button with the "arrow pointing into a box" at the very top left of the Developer Tools window to "inspect an element" (or hit cmd+shift+c).
    4. Click the Netflix video element to inspect it. This should bring up the Elements tab in the Developer Tools window with the "video" element selected.
    5. At the top right of the Developer Tools window, you should see a little section that says "element.style" with a few list items underneath. Click the bottom of that section and add opacity: 0.996 !important; as a new list item.
    6. Go full screen and watch a beautifully artifact-free video.

    You'll have to do this every time you open a new video in Chrome, but it only takes a few seconds. I'm sure it can be done more permanently with an extension, as @chris-l said though.

    PS: Thanks to the f.lux team for a great piece of software! It's a lifesaver. I know this bug isn't your fault.



  • I'm even having this problem with the new update. Before everything was working fine, now i start seeing some difference on the white color when i'm full screen on youtube. After all the buttons hides, the color white become strange.
    I'm using MacBook Pro Mid 2015, Intel Iris Pro 1536 MB



  • Here, you can try this as a Chrome extension.

    https://chrome.google.com/webstore/detail/videofixer-for-flux/gmkeppffdejhpppfnbgakglpoeaobhhh

    I submitted one for Safari but they have to approve it. (Or reject it!) But if you know what you're doing the source code is here. https://github.com/clundie/VideoFixer


  • f.lux team

    @chris-l wow this is awesome - thank you!


  • f.lux team



  • @herf where can I get older versions of f.lux? I didn't have this problem before I updated it.



  • @herf don't mind that, it seems to appear after Chrome is updated.



  • Whatever this is, I don't have this problem in the incognito mode, Safari and another user's Chrome. But the Chrome I use have this color artefacts.

    The above css fixed that. For anyone who's concerned about the reduced opacity I'd recommend using box-shadow, which is what I did with the Stylebot extension. Tested only on youtube.

    .ytp-fullscreen video, #netflix-player.player-cinema-mode video {
        box-shadow: 1px 1px 1px rgba(0, 0, 0, 0) !important;
    }
    

    @chris-l I think it's better to use box-shadow in your extensions as well.



  • This post is deleted!


  • Thanks for the feedback, I will try to look into energy usage & see it it makes a difference. Also I should point out that the browser extension is applying the style to all videos, not just YouTube & Netflix. In future I might make it more specific again, though it does mean we would have to deal with changes to web site designs that break it.



  • Now Safari is just fine but Chrome isn't lol

    Safari has noa artifact whatsoever since I updated to Safari 10.

    Is it just me?



  • @chris-l thanks for the extensions! Does this apply to all videos, or only full-screen playback? I haven't tried it yet, but I think lowering the opacity would have some undesired effect on the color and contrast, no?



  • @Nirvanes said:

    Now Safari is just fine but Chrome isn't lol

    Safari has noa artifact whatsoever since I updated to Safari 10.

    Is it just me?

    Have you tried Netflix? Youtube seems to be a lot better but I definitely still get artifacts with Netflix.

    @chris-l The Chrome extension definitely works. Youtube looks absolutely fine. Thank you!



  • Thanks for the feedback. Yes the extension is applying to all videos, full screen or not. The opacity is only reduced by the smallest possible amount, so I would hope it has minimal to no perceptible effect. (Only 0.4% of the background color will be blended into the video). But yes there are other ways I could try -- like the box-shadow rule that was mention earlier. I think what we are doing is forcing the browser to render the video in a way that doesn't trigger the bug. Probably there are a bunch of ways to do it.



  • @mixolyd said:

    @Nirvanes said:

    Now Safari is just fine but Chrome isn't lol

    Safari has noa artifact whatsoever since I updated to Safari 10.

    Is it just me?

    Have you tried Netflix? Youtube seems to be a lot better but I definitely still get artifacts with Netflix.

    @chris-l The Chrome extension definitely works. Youtube looks absolutely fine. Thank you!

    Tried it a little, need to give it a go, but I didn't notice anything.

    Youtube is like it should right now, I just don't ironic that now that Safari is alright Chrome isn't... I only used Chrome to watch Netflix and Youtube at night, nothing more.



  • MacBook Pro (Retina, 13-inch, Early 2015) - Intel Iris Graphics 6100 1536 MB

    Have been having issues both in Chrome and Safari with this neon affect coming on while I am trying to watch Narcos... as well as in YouTube, at first I thought it was my computer graphics and was getting worried, but when disabling f.lux (v 37.7) the problem is solved. This is a bummer as I need f.lux to help me maintain my sleep cycle and I watch a lot of videos at night. I tried the f.lux fixer chrome extension, but it only worked for youtube



  • I'm having the same issue for Netflix and YouTube on Chrome. My OS is 10.11. Macbook Pro Retina 15 inch mid 2014. Graphics Intel Iris Pro 1536 MB. Problem goes away when I disable Flux.



  • I hope this helps at least SOME people. I simply went into system preferences > energy saver. Then on the top left of that page I unchecked the "automatic graphics switching" box. Suddenly I can fullscreen everything with no issue.


  • f.lux team

    @isayuh Thanks - this avoids the issue, which appears to happen with Intel GPUs, by using the discrete GPU instead (NVIDIA or AMD, which do not have the problem). Of course, it only works on machines with two GPUs.



  • Happening on the new 2016 MacBook Pro. 'About This Mac' specs below.

    OS: macOS Sierra (10.12.1)
    MacBook Pro (13-inch, Late 2016, Two Thunderbolt 3 ports)
    Processor: 2 GHz Intel Core i5
    Memory: 8 GB 1867 MHz LPDDR3
    Graphics: Intel Iris Graphics 540 1536 MB



  • @omgwtfbbq you already got the new macbook pro, that's keel. Does it run less hotter than previous models?

    But css above should fix for you too.



  • @ik... It's great! Running a lot cooler and way quieter than my Mid-2014 Retina MacBook Pro.
    I'm just concerned the CSS fix will cause excessive CPU/GPU usage in compositing the filter over the video?



  • @omgwtfbbq So cool, I'm sitting with my late 2013. It will last me a long time thanks to ssd and retina.

    I don't really remember why this fixes the issue, I think it makes an element render differently. It's not like it's switching off hardware acceleration or something. I'm sure it will be insignificant comparing to actually playing a video.


  • f.lux team

    @omgwtfbbq I would guess that the CSS just turns off the "fully accelerated" path, but it is still using the GPU to do the compositing and decoding. (i.e. there is likely a battery hit but it may not be very big.)



  • @herf Makes sense. I've found that the issue occurs when the video is the primary element in focus on the screen.
    If a banner ad, video controls, system volume controls, etc are the primary window then the issue does not occur. Whereas if the video is then it occurs.


  • f.lux team

    Update:

    Apple has reported this video bug fixed in the latest Safari. This seems to be true. Progress! (Thanks Safari team!)

    However, because it is fixed in Safari, it still appears in several other apps that play video, including desktop Quicktime and Chrome (AVFoundation or QTKit? We don't know.) For now, Chrome users should use the plugin.



  • It seems with the new Netflix player the problem has been fixed in Safari. I've been watching netflix all day and haven't seen the blue fringed mouse pointer.



  • I'm still having this bug in Safari, but not all video. Youtube is mostly fine, but most other videos have the color issue.
    Mid-2013 Macbook Air, Sierra 10.12.1, Safari 10.0.1



  • I'm still having this issue too, and it's very irritating. Weirdly, a similar thing is also happening from time to time on my iPhone, which does not have f.lux installed on it, but is using Apple's new built-in Nightshift.

    Mid-2012 MacBook Pro, El Capitan 10.11.6, Chrome 55.0.2883.75


  • f.lux team

    @applewaffles Oh, gee. I do promise it's not our bug, I guess that's further evidence. Do you have reduce white point turned on for your iPhone by any chance? Turning it off may help.

    Updating the OS and to the latest Safari should fix the artifact problems in everything in Safari. I don't believe it's fixed for non-Apple apps.



  • @kcds I have the exact same problem.



  • For the record, I still get blue artefacts in Safari using f.lux on the very latest Safari. Mac is the 2016 12", so the newer (problematic) GPU.

    I don't know what the update was supposed to improve, but it hasn't worked in my case.

    @chris-l 's extension is great for Chrome! So that's a plus. But I don't yet know how to make a Safari extension from what's on the GitHub. (GitHub noob. Hopefully I can work it out!)



  • I'm assuming this wasn't fixed since I'm having the same issue. I have a late-2016 MacBook Pro 13,1 running Intel Iris Graphics 540 and macOS 10.12.2. This is happening with any video I run in full screen on Chrome 54.0.2840.98. I don't use Safari so I can't speak to that.