Strange colors/blue-fringed mouse pointer on full-screen YouTube when f.lux is active



  • I also have the issue on all hardware accelerated video.
    I am using Safari Version 9.0.1 (11601.2.7.2) on OSX 10.11.1
    Computer is a mid-2013 MacBook Air with HD5000.

    I've had this for a really long time now, I think forcing the hardware acceleration off is necessary until there is a "good" fix for it. As soon as I move the mouse or exit fullscreen, everything is normal. But I can't or rather don't want to constantly keep moving the mouse through videos or streams (It happens on live streams, too - twitch.tv for example)



  • this issue is not happen in chrome!


  • f.lux team

    I can do the overlay in Chrome (where it doesn't help) but in Safari it creates a whole new desktop (fullscreen app through Mission Control) and is quite intent on making that the only app. It might be possible with a Safari extension, but it wasn't as easy as I thought!

    El Capitan has a new splitscreen view...probably wouldn't help but someone could try it. :)


  • f.lux team

    Also if you're seeing this on Youtube or somewhere we can test, please post a link.

    This stopped failing on 10.11.1 on our Macbook Air (HD5000).



  • I still have the issue with 36.4 on El Capitan 10.11.1 with my MacBook Air 11" 2015. This is a video I just watched the following video, you can start at 1:00 and as soon as you stop moving the mouse, the artifacts appear. https://www.youtube.com/watch?v=5hirxcWeG4Q



  • Same issue here : MBP 13" mid 2015 osx El Capitan 10.11.1 using Safari, however, i dont have any blue fringed blue color on my mouse.
    I really got used with f.lux colors at night, i can't disable it only for few minutes to watch a full screen video
    So, the only way i found to avoid this bug is to let my mouse cursor on the the play button of youtube.



  • @herf Still happening on my Macbook Air (HD4000) w/ 10.11.1. seajay's youtube link earlier is a perfect example because of the white background right at the start.



  • Hi macbook air core i7 intel hd 5000 here and with El capitan 10.11.2 The last update i've just did the blue glow is here before i had no problem.

    So sadly i decided to uninstall Flux 'cause the blue glow was very very annoying.

    I hope you guys can solve it!



  • Same here. Macbook Air 13, 2013, HD 5000. Still no fix.



  • Macbook Pro Retina Mid 2014 13". Intel Iris 1536MB graphics.. Having the issue as others have reported.

    Very obvious on this video https://www.youtube.com/watch?v=z3HvchF49AM.

    It's been months since this thread was started.. is there still no fix?

    Cheers!



  • This happens to me on this video (while in full screen), can be seen at around the 4:20 mark https://youtu.be/Ct9tSXbHL9M?t=4m16s
    I can confirm that it does not happen with Chrome, only Safari. I'm on 10.11.3 Beta (15D9c), MacBook Pro (Retina, 13-inch, Mid 2014)



  • This is happening with Netflix too trough Safari (of course)



  • This post is deleted!


  • This post is deleted!

  • f.lux team

    Deleted off topic posts, please keep it related to reporting bugs.



  • I have this problem as well, at least since the summer of 2015 but probably longer. However, closing flux doesn't help me. Tried closing it and rebooting Safari without flux but I still got this problem.



  • I found that when I activate (and then deactivate if I want to) another of my extensions I don't get the overlay colour disruptions when I go to full screen. (Limited testing has been done.)
    EDIT: Seems to work ok on youtube, not on netflix.



  • Same problem on full screen youtube videos when I don't move the mouse for a few seconds.

    MacBook Pro (Retina, 13-inch, Mid 2014)
    Intel Iris 1536 MB

    El Capitan 10.11.3



  • Hello, this is happening to me too, MacBook Air (13-inch, Mid 2012) with Intel HD Graphics 4000 on OS X 10.11.3 (15D21).



  • Also happening to me:
    MacBook Pro (Retina, 13-inch, Mid 2014) Graphics: Intel Iris 1536 MB
    El Capitan 10.11.4 Beta (15E27e)



  • It seems it was fixed in the latest (today) update?! At least YouTube is ok at this moment.



  • @Adrián-Mihálko Not for me (MacBook Pro Retina, 15-inch, Mid 2015 with Intel Iris Pro 1536 MB).



  • There seem to be several threads about this so I'll chime in on this one as well. Same problem.

    MacBook Pro (Retina, 13-inch, Early 2015)
    Graphics: Intel Iris Graphics 6100 1536 MB
    OS X El Capitan 10.11.3 (15D21)

    I've just installed the most recent f.lux update (36.6).



  • 8 months and still not fixed...



  • Hi! I've made a topic about this problem in Apple Forums. Please comment there and let them know that they need to pay attention to us!

    https://discussions.apple.com/thread/7455881

    And report it through product feedback http://www.apple.com/feedback/

    We need to get their attention, wa lot of people need to talk about this problem.



  • did i miss an update? running 36.6 and it is still happening.



  • Same problem, started when I upgraded to El Capitan a couple weeks ago.

    Macbook Pro Retina (Mid 2012) HD 4000
    Safari 9.0.3
    Flux 36.6
    I hadn't updated my OS until El Capitan, I think it came with Lion. I see from the thread this issue has been longstanding but my old OS did not have this issue, the update to El Capitan is definitely when it started for me.



  • @seajay Oh yeah, that's a great video for demonstrating the issue. Seeing more distortion on this than most other vids.



  • Same problem with my MacBook Pro Retina mid-2014 Intel Iris



  • I have the same problem with my MacBook Pro 13" Retina 2015 (running OS X 10.11.3).



  • Me too.
    OSX 10.11.3 (15D21)
    Model Name: MacBook Air
    Model Identifier: MacBookAir6,1
    Processor Name: Intel Core i7
    Processor Speed: 1.7 GHz
    Number of Processors: 1
    Total Number of Cores: 2
    L2 Cache (per Core): 256 KB
    L3 Cache: 4 MB
    Memory: 8 GB
    Boot ROM Version: MBA61.0099.B21
    SMC Version (system): 2.12f143



  • I've got a Mid-2015 13" Retina running 10.11.3, Flux 36.6 with the Intel Iris 6100 doing this exact issue.

    I can reliably reproduce this when running in the default "looks like 1280x800" Retina mode. When I change to the "more space" 1680x1050 mode, the issue goes away (and vice versa) - I guess that's why I haven't noticed it until recently as I usually use the more space mode.



  • Same problem here on a 2015 MBPr with Intel Iris Pro. The problem goes away when I disable automatic graphics switching and use the Nvidia card.



  • Same issue.

    Flux 36.6
    MBA 2014 (hd5000) -- OS X 10.11.5



  • The f.lux team hasn't replied on this topic in 9 months. Is anybody working on fixing this problem?


  • f.lux team

    There is a bug in to Apple, but this is way below us in the system.

    All we can do is recommend you disable f.lux while playing a movie.



  • This happens on a Retina MacBook too (2015) with H5300 graphics, and OS X 10.11.6.

    Has anyone seen this issue in MacOS Sierra too?

    I'm guessing this won't be resolved without Apple's input, and/or if Apple introduce Night Shift on MacOS..



  • Just thought I'd say that this bug is still active with HD graphics 4000 on my mid 2012 macbook pro.

    When I use gfxcardswitcher to force discreet card while using youtube the issue does not appear.



  • Same issue as mentioned by users.

    This issue is while I play fullscreen videos on Youtube, Udacity. Whites are blown out, blue hues here and there, if you move the cursor the problem goes away for a while and then comes back.

    Also this is not just in Safari, it does the same in Chrome too.

    I am running
    f.lux version 37.7
    MacBook Pro (Retina, 13-inch, Late 2013)
    Intel Iris 1536 MB
    OSX version 10.11.6 El Capitan

    This annoying bug has been reported a year ago and it is sad to see that there is no fix yet. I have used F.lux on windows for long and this bug on Mac is kinda making me look for alternatives to F.lux which I really don't want to do.

    Please try to fix this.



  • @shinz4u Agreed, it's a very disappointing lack of action.

    It makes the program completely useless in my opinion. If I have to keep turning it off, it is doing me no good in terms of helping with my body's sleep cycle confusion.

    Flux replies so far have indicated there will be no fix. I'm still following the thread and hoping they sort it out, but it doesn't seem like anybody cares or is working on it. Can anybody recommend a different program? I give up with this.



  • I've gotten around the issue thanks to this little app: Shady for Mac.

    What's a little strange but very good for this specific purpose is that just running the app with the "shade" setting off still fixes the problem. I'm guessing it's doing something similar to gfxcardswitcher in the background, as soon as it's running, so it's probably affecting battery life too (although I haven't paid attention to that myself).

    And of course, turning the thing actually on and reducing the brightness to a minimum ain't bad for your eyes either.



  • This post is deleted!


  • I worked around this by creating a file named safari.css, a text file with these contents:

    .ytp-fullscreen video {
      opacity: 0.996 !important;
    }
    

    Then in Safari preferences > Advanced, you select that file for the Style sheet setting.

    If you want to experiment, every time you edit & save that file, you have to reset the Safari preference back to None Selected and then back to your file.



  • My solution might reduce battery life a bit, hopefully it's not noticeable.



  • You could add Netflix to it if you want:

    .ytp-fullscreen video, #netflix-player.player-cinema-mode video {
      opacity: 0.996 !important;
    }
    


  • @chris-l

    Hi, is there such a preference in chrome for mac that I can change to get a similar solution?

    Thanks a lot



  • @shinz4u Sorry, not sure about Chrome. There are probably extensions available that let you add your own CSS rules, but I haven't looked into it. I might publish my own extensions to make it easier for everyone.

    I actually am not using f.lux at the moment, but I calibrated my laptop display with a lower color temperature than normal, and it has the same bug that you get with f.lux -- videos have artifacts in the brightest parts, but only when they are full screen with nothing else composited on top of them. Maybe the video driver uses an optimization for this case that doesn't quite work.



  • @shinz4u I just figured it out in Chrome. Thanks @chris-l for the fix! This thing was driving me nuts.

    Quick guide for web devs: Just add opacity: 0.996 !important; to the HTML5 video element in Chrome's developer tools.

    Detailed steps for non web devs:

    1. Open a tab with the Netflix video you want to watch (haven't tried with YouTube, but same principle should apply).
    2. Open Developer Tools by going to View > Developer > Developer Tools (or by hitting alt+cmd+i).
    3. Click the button with the "arrow pointing into a box" at the very top left of the Developer Tools window to "inspect an element" (or hit cmd+shift+c).
    4. Click the Netflix video element to inspect it. This should bring up the Elements tab in the Developer Tools window with the "video" element selected.
    5. At the top right of the Developer Tools window, you should see a little section that says "element.style" with a few list items underneath. Click the bottom of that section and add opacity: 0.996 !important; as a new list item.
    6. Go full screen and watch a beautifully artifact-free video.

    You'll have to do this every time you open a new video in Chrome, but it only takes a few seconds. I'm sure it can be done more permanently with an extension, as @chris-l said though.

    PS: Thanks to the f.lux team for a great piece of software! It's a lifesaver. I know this bug isn't your fault.



  • I'm even having this problem with the new update. Before everything was working fine, now i start seeing some difference on the white color when i'm full screen on youtube. After all the buttons hides, the color white become strange.
    I'm using MacBook Pro Mid 2015, Intel Iris Pro 1536 MB



  • Here, you can try this as a Chrome extension.

    https://chrome.google.com/webstore/detail/videofixer-for-flux/gmkeppffdejhpppfnbgakglpoeaobhhh

    I submitted one for Safari but they have to approve it. (Or reject it!) But if you know what you're doing the source code is here. https://github.com/clundie/VideoFixer