NVIDIA "purple screen" issues (387.68) ["...387.92 fixes everything"]


  • f.lux team

    We are getting lots of email about an NVIDIA "purple screen" bug today. As far as we know, this is due to a recent automatic NVIDIA driver update (387.68) and not due to any recent changes in f.lux.

    If you are seeing it, please rollback your drivers to the previous version, or to a newer version when one is available.



  • If I think the "purple screen" is the issue I had, that completely white colors are unaffected or even tinted purplish but everything else is fine. Then I might have a solution that worked for me just now. Instead of uninstalling the current drivers and installing an older version of my NVIDIA drivers I just reinstalled the complete NVIDIA Gforce Experience with the latest version (387.69) and it fixed the problem



  • You guys all mean 385, right? I see no newer drivers than the 385 series... Anyway, I still have the problem in 385.74!

    I uninstalled all NVIDIA stuff including GeForce Experience (since it keeps automatically updating to the latest broken driver version all the time) and installed the 385.41 drivers. So far no problems! Will report back if it changes.

    The bug also affects Windows' own Night Shift, making it look wrong in the same way as f.lux - so it is definitely not a f.lux bug.

    @Nanabell Reinstalling as you had suggested only worked until the very next reboot for me!



  • I'm still also seeing the problem with 387.78 :(



  • I think what all these people forgot to mention is that they're using the Insider Builds of Windows 10 ;)

    For me on the current stable branch of Windows (build 15063.608) and NVidia driver 387.78 everything was OK, I got this driver by switching to Insider Build "Just fixes, apps and drivers".

    Today, since the RTM candidade was released (16299.15) I updated to it and with f.lux turned on everything looks like yellowish-piss to me, not purple. :(



  • @Shoonay
    Im on 16299 as well, but I think its directly linked with grahpic driver, however I'm on AMD (17.9.3 [23.20.768.12]) not NVIDIA.
    At worst it can be just combination of both (I can confirm it has exactly the same issue with Windows' "Night Light")
    Will revert to 17.3 and see if that fixes it.



  • I can confirm reverting to Radeon 17.7.2 (the recommended version) fixes the issue completely.



  • @Rafal-Trzewikowski

    Hmmm, perhaps it has something to do with the driver model?
    DirectX Diagnostic Tool showed this driver's (387.68) WDDM as 2.2 on the previous (15063.608) Windows build, while on 16299.15 it's WDDM 2.3 so maybe it's that.
    Too lazy to downgrade the driver and check, guess we will have to wait for 16299 a new graph driver to officially come out...



  • Driver updated to 387.87 and problem still not solved.



  • Had 387.78 drivers and Windows Insider, reverting to 385.69 fixed the issue.



  • I set the output color format of NVIDIA on the control panel to YCbCr444 and then back to RGB, and the purple screen disappeared. but after rebooting it is necessary to repeat



  • Driver 387.92 fixes everything! :D



  • thread closed



  • NVIDIA drivers version 387.92 also resolved this issue for me. I am also on an Insider Windows build (release preview mind you).


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.