Phillips Hue lights are very dimmed



  • I just setup my Philips Hue lights. In fact, one of the primary reasons I bought them was I saw they worked with f.lux!

    I got them paired okay, and f.lux is in control of the lights. However, the light brightness is maybe at like 20% and I can't seem to get them to go any brighter. It is 11PM here right now, and the reverse alarm clock is telling me I have to be up in 9 hours. Not sure if that has any impact on the integration or not.

    If I go into the Hue app and adjust the brightness of the room it immediate gets overridden by f.lux, putting the lights back to the really dim mode.

    Thanks for your help!


  • f.lux team

    Sorry, we had a ton of brightness features we ripped out at the last minute because they weren't reliable on every machine. Hue is the only thing still using them!

    Try using this .reg file to set all the states to a brighter setting:

    https://justgetflux.com/misc/huebright.reg

    f.lux will still dim somewhat to match the dimming we do with your screen, but it won't be as much as the defaults.



  • Awesome. Thanks for the quick response! I ran the reg update and will see how things look later tonight. So far so good though. Glad to know I can go tweak those values so easily. As a feature request, it would be awesome to have a settings page in f.lux to manage those values.



  • Hello! I've been having the same problem with Hue lights being dimmed, even after the registry update.

    The main issue I am having is that both "night" and "late" dimming bring my hue lights to a brightness at which I can't read papers on my desk.

    Is it possible to modify the application behavior so that the modified registry values (at daybri, nightbri, latebri = 0x3e8) result in no dimming (only color temp change)? Then, modifying the registry values below 1000 would induce dimming.

    Thank you!


  • f.lux team

    @aeonflux how far away are your lights from your desk? We could add more registry junk to change the dimming feature as a stop-gap. :)

    And thanks - yes we are going to need to add more controls. The current feature is mainly designed to match the luminance change of the screen at the same time. So basically, what we're doing right now is trying to help the screen look better by adjusting the lights. If we make the screen dimmer but the lights stay the same (like they do in most places), then glare increases and you can't read your screen.

    But that certainly isn't at all the same problem you have when you're trying to read a book.

    I haven't committed to "Hue" as opposed to "lots of connected lighting" so the reason the UI is pretty spartan is that I'm trying to make it work with everything before I make everything adjustable. This is a big focus for us, so hang on and we will get there. :)



  • I'm experiencing a similar issue. It would be nice to have control over whether f.lux controls the bulb's brightness or not.


  • f.lux team

    Ok, we found a calibration issue that will be fixed in the next version, so they will be somewhat brighter (but not the brightest...until we add more UI).



  • @aeonflux Did you make sure to completely exit flux before updating the registry? I made that mistake a couple times and found that flux kept overwriting the default values if it was open in the tasktray. What I did was:

    • Menu->Exit f.lux
    • run .reg,
    • re-opened f.lux

    and my Hue lights are working fine now!



  • Hmmm, it appears I may have spoken too soon... Daytime seemed fine, but now that it's getting into the evening I see that the brightness is decreasing alongside colour temp :-| Still better than before, but I'll definitely be hopping on the newest version as soon as it's available! I bought the Hue lights because I just discovered f.lux (yeah, i'm a bit behind the times) and saw it had this ability; can't wait for it to be fully functional :)

    Cheers, and thanks for creating this software!
    Dan

    @alteramaxplus said:

    @aeonflux Did you make sure to completely exit flux before updating the registry? I made that mistake a couple times and found that flux kept overwriting the default values if it was open in the tasktray. What I did was:

    • Menu->Exit f.lux
    • run .reg,
    • re-opened f.lux

    and my Hue lights are working fine now!


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.