[fixed] Flux applies a different color temp when on Desktop



  • When "disable for fullscreen apps" is turned on, Flux applies a different (less red) color temp when I'm on the desktop (4.41). Is this on purpose or is this a bug?
    Update: it's only happening when I only have a single monitor. If I enable additional displays, the issue is gone.
    Just for info, I'm on Win10 November Update, and I have a GTX 1080.


  • f.lux team

    How fast does it adjust? We should not be changing anything for the desktop...or that's a bug.



  • it's immediate, and the filter pops back as soon as an app has focus. but only the red tint disappears during this time, the dimming stays.



  • Yes, i can confirm this behavior. Having the same issue.

    OS: Windows 10 Pro (up-to-date)
    GFX: Intel HD Graphics 530 and NVIDIA GeForce GTX 950M

    My settings are: Disable -> [checked] for full screen apps

    It behaves like if Desktop would be treated as full screen app since issue is no longer present if i: Disable -> [unchecked] for full screen apps.

    It takes about 0.5 to 1 second for switch to happen.

    I would also point out that i am having strange issue with right-mouse-click on tray icon of flux. Menu quickly shows and disappears again and it takes a couple of tries for me to be able to show menu normally. Sometimes it works ok. Strange.
    I don't know if this is an issue of my OS (Windows 10 Pro) or my system configuration or is it actually something that f.lux can and should look into.


  • f.lux team

    Think I untangled this one - fixed in 4.43.

    Get the 4.43 build at https://justgetflux.com/flux-setup4.exe

    Also check the "beta" option in the about box.



  • Yes, the fix works for me! Thanks!



  • Yes! It also works for me. Thx!


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.