Build 37.7 for El Capitan


  • f.lux team

    There's a new build for El Capitan users - now the main download after a few days of testing. This build will not work on 10.6.

    Most people will get an update in the next few days.

    What's new:

    • Fix for a battery drain issue on some machines
    • Fix for flashing with "movie mode" on some machines
    • Updated Sparkle (automatic updater)
    • Now 10.7 minimum (and 64-bit only) due to the Sparkle update
    • Support for "big" latitudes where the sun doesn't set or rise some days
    • A "check for updates" button, by popular demand
    • Some fixes for darkroom mode

    What's not fixed on all machines (because it's outside our control):

    • White spots on video with Intel video

    To download:
    https://justgetflux.com/



  • It worked really well on OS X 10.11.

    The OS X dark theme on sunset function only changes the color of the icons, but not the theme, on macOS 10.12. It's a developer beta, so I am just reporting it, and I am not expecting a fix very soon :)


  • f.lux team

    @Tzm41 thanks - we will wait to see where this goes, but we may have to turn the feature off depending on the update.



  • I'm having a flickering problem in both 37.1 and 37.2 in OSX 10.11.5, Chrome Version 51.0.2704.103 (64-bit)...the flux color changes turn off and on really fast. At first I thought it was only during transitions, but it is happening all the time. This seems to be a purely Chrome thing.


  • f.lux team

    Have you rebooted since installing 37.2? This usually helps.

    If you can't reboot, disable "automatic brightness" until you can.



  • @herf turning off the automatic brightness seems to have fixed it. (I haven't turned it back on but I have rebooted). As to why it was only happening in Chrome, I don't know.



  • I'm having an issue with flux turning off when I adjust brightness of my display. It doesn't seem to flicker any more, though.

    If I turn the brightness up or down, flux goes off for a good second or two.

    Any ideas?



  • @herf do we need to update if using 10.10.5 yosemite & mountain lion? TIA



  • using version 37.2 on 10.11.5 with amd radeon 6970. Default settings. During the first day of launch after the latest flux update the app worked fine, but the 2nd day in the morning it went nuts and got stock in bedtime mode, quit the program from the menu and still the screen color didnt change. finally had to reboot to fix it.
    Since then it randomly changes settings during the day, sometimes bedtime, sometimes sunset, regardless the hour. and if i quit the app the color profile sticks. reboot and reboot.
    Long time user, really like the app, but this is frustrating.



  • @carlosfescobar said:

    using version 37.2 on 10.11.5 with amd radeon 6970. Default settings. During the first day of launch after the latest flux update the app worked fine, but the 2nd day in the morning it went nuts and got stock in bedtime mode, quit the program from the menu and still the screen color didnt change. finally had to reboot to fix it.
    Since then it randomly changes settings during the day, sometimes bedtime, sometimes sunset, regardless the hour. and if i quit the app the color profile sticks. reboot and reboot.
    Long time user, really like the app, but this is frustrating.

    Having exactly the same issue! Flux is going nuts, even if the tray application is quit.


  • f.lux team

    Does your display have a default color profile ("Color LCD")?



  • @herf Nop, not listed. before flux i was using the default profile, im on an imac 27 btw.


  • f.lux team

    So it only lists "f.lux profile" and nothing else?

    Or are there two listed?

    During the day, f.lux tries to re-select the default one. I'm wondering if some models don't have one anymore?



  • I have three monitors hooked up to my iMac and since upgrading to 37.2 my iMac monitor does not return to day mode when the other two external monitors do.



  • I have installed 37.2 on My MacBook Pro (13-inch, Early 2011) running OS X 10.11.5. My laptop have Sudden Motion Sensor (SMS). When I move my laptop, it affects flux functionality. For example when flux is disabled at day, moving my laptop suddenly makes flux enable! and vice versa.
    Is it a bug? Or is it a compatibility issue with older MacBooks?


  • f.lux team

    This post is deleted!


  • @herf this worked for me!


  • f.lux team

    @mayhem Great!



  • @herf :( installed yesterday but no change for me, just jumped back to sunset mode, quit flux and a few minutes later the profile activated again with the app closed. Reboot.



  • I may have spoken too soon.. the night time color was much faded from the previous version, but the day time colors were not in effect. Today, the night mode colors were still present on the main iMac monitor while the two external monitors are set correctly. Sorry for the false positive.



  • a bit more info, pressing the Daytime, Sunset and Bedtime buttons works perfectly with all three monitors.


  • f.lux team

    Can you post the exact model Mac?



  • @herf iMac 27inch mid 2011. AMD Radeon HD 6970M 2048 MB


  • f.lux team

    Questions:

    1. Does the bug still happen if you run "Calibrate..." on the display (System Prefs > Displays > Color)?
    2. Does the bug happen on wake from sleep, or at other times?
    3. Is the f.lux profile selected when the bug happens?

    Based on earlier reports, I'm assuming this bug goes away if automatic brightness is turned off.



  • @herf my answers:

    1. haven't tried recalibration.
    2. on wake from sleep the morning after the last restart
    3. yes, the flux profile is selected, as soon as i select the imac profile (in my particular case) it resets to normal color... a few minutes after it changes color again until i reboot. Tried uninstalling flux with appzapper and removing the flux profile manually, still changes color after a few minutes until i reboot.

    hope this helps.


  • f.lux team

    My theory is that the automatic brightness feature in the OS is seeing f.lux as an "interesting" profile (not the default one), and it is holding onto it, beyond when it should.

    So, when we reset the profile, it keeps using ours. "Calibrate" might provide an alternative 'interesting' profile to use instead.

    There should be two workarounds as of the current build:

    1. Disable automatic brightness (the new system that's doing this, in 10.11)
    2. Disable f.lux's profile writer: https://justgetflux.com/news/2014/10/28/profile.html - this may cause some flashing when the system switches between video cards (AMD <-> Intel)


  • @herf Will try your suggestions. FYI i disabled automatic brightness when the problem started, so 37.3 never had it applied.


  • f.lux team

    @carlosfescobar FWIW: on the PC we have seen some strange behavior due to AMD drivers (holding onto profiles), but I have not seen it previously on the Mac. Another option is to investigate which GPU is active at the time with https://gfx.io/



  • @herf said:

    Questions:

    1. Does the bug still happen if you run "Calibrate..." on the display (System Prefs > Displays > Color)?
    2. Does the bug happen on wake from sleep, or at other times?
    3. Is the f.lux profile selected when the bug happens?
    
    1. Just re-calibrated.. I will find out.
    2. Wake from sleep and other times.
    3. No.

    I also turned out automatic brightness.



  • @herf So when's an official fix coming please? It's driving me nuts too ... I suspect Chrome may also be a factor here. MBP Mid 2012 Retina 15".



  • @herf Thanks. It seems that the bug is solved in 37.3.



  • do we?? really dont know



  • Since I upgraded to Build 37.2 with El Capitan, I have been getting orange screen often during the daytime. Also as noted in another post, this does not necessarily go away if I quit f.lux. This is just using safari or email. Can anyone help?



  • @pyris I have the same issue.

    Guys, please fix this. Since I upgraded to 37.2, I constantly get the "orange screen" i.e. "Bedtime" during the day. Mostly before noon. I then quit f.lux and the screen gets reset to "daytime" mode, but after a while it switches itself to "Bedtime" again even though the f.lux app isn't started. When I start f.lux, then screen fixes itself again. I'm doing this on and on and it drives me nuts.

    I went to System Preferences and disabled "Automatically adjust brightness", but that didn't help.

    I'm using El Captian 10.11.6 Beta (15G26a). I was also using an El Capitan Beta with f.lux v36, but I had no problems then.


  • Android

    @herf It appears with this new build that f.lux is deleting its color profile when it is daytime. Is this intended behavior or a bug?


  • f.lux team

    @agottschling yes 37.3 does this - it helps fix unplugged monitors. Previously (37.2) f.lux would select the "old" profile and leave the last "f.lux profile" there. It doesn't seem that 37.3 has helped much.

    What's happening with the new 10.11.5 OS is that the system is remembering our profile even when we tell it to use the default one - in fact, unless we constantly tell it again and again to stop doing it (which is very expensive).

    Regarding the v37 update: the previous build (v36.6) in some cases was constantly setting your profile because the OS told us it was always changing, which is about 100x as expensive as not doing so. Apple seems to have fixed most of these bugs so far, so we released 37 after a few weeks of testing, and it's less aggressive about fixing this case.

    The remaining bugs seem to be related to Radeon chipsets and sometimes to automatic brightness. I'm trying to sort out which is which.

    It's complicated because we don't have a machine in-house that's exhibiting the bug.


  • Android

    @herf Ah. I understand now. I've got a MacBook Pro with the dual gpus (Radeon 6750m and Intel HD 3000). If I can be of any help testing, let me know.


  • f.lux team

    @Katya-K. Can you post your machine type (and GPU type) also? thanks!



  • @herf

    Sure, here's my iMac info.

    alt text


  • f.lux team

    Ok - the case that reliably fails for me on our Intel/NVIDIA machines is this one:

    1. Enable automatic brightness
    2. Disable it.
    3. Don't reboot!
    4. ...

    So if you are in this state, please reboot and don't change the automatic brightness setting after. AMD may be still another case.



  • Just wanted to say it seems the issue no longer occurs on my side. Here is what I remember I did:

    1. Installed f.lux 37.2
    2. Preferences -> Displays -> Color. I removed the f.lux display profile.
    3. "Automatically adjust brightness" stays enabled.
    4. Rebooted my iMac

    I thought f.lux is not going to work after I removed the profile, however, it does seem to work. I'm using the Classic f.lux theme. I'll update my info should any changes occur.


  • Android

    OK. I've found a replicatable scenario that will cause f.lux to get stuck, and whenever I leave Google Chrome open but minimized, it can "remember" the f.lux color profile such that when I maximize it, it will revert the display back to the old color. I'm running the latest stable build of chrome and flux 37.3.



  • Hi everyone,
    I have the following issue:
    When using f.lux in the evening and shutting down my computer, the next morning when I reboot my Computer the warm color temperature is active and my screen is, like in the evening orange. Only after a few seconds I got a flicker and the right temperature (6500K) is set.
    Can anybody help me?
    Thanks in advance. :)
    By the way ... I am running Mac OS X 10.11.6 (Macbook Pro Retina, 15', Mid 2014)/ 2.5 Ghz Intel Core i7 / 16 GB 1600 Mhz DDR3 / NVIDIA GeForce GT 750M 2048 M


  • f.lux team

    I think this is expected to work this way (f.lux doesn't get time to run immediately on wake or reboot, so it takes us a minute to fix things from the previous night).

    Do you sleep the machine or shutdown? Sleeping might fix things a little faster.


  • f.lux team

    @agottschling please send your system info and if you're using automatic brightness or not?


  • Android

    @herf Specs

    I do have automatic brightness turned on.



  • I'm also having this exact issue, except I am on 10.11.5. I ended up reverting to 36.6, and will keep using that version until this can be sorted out.



  • Can you please tell me how to disable or remove this terrible version of f.lux? I love the software but versions 37.2 and 37.3 are driving me INSANE, switching to sunset all through the day, whether I enable or disable the app. And now, having completely quit f.lux, and DELETED both the f.lux profile and then the Color LCD profile, it keeps switching my display to sunset mode. Despite not being enabled and there being no f.lux profile present for the monitor. What is going on??
    Mid 2012 Retina MBP, OS X 10.11.6, running on Intel integrated graphics.


  • f.lux team

    Can someone please set your daytime color temperature to 6400K and see if this helps?



  • @herf I've done that now - will let you know if it misbehaves. Time is 9:55am AEST here (and time zone is set based on location).


  • f.lux team

    @MatthewK thanks - I have two workarounds in mind, and one is basically a less noticeable version of this - but I'm hoping this works.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.