Fullscreen youtube colour artefacting.



  • I'm still having the same issue in OS X El Capitan Version 10.11.3



  • @David-Schlachter It seems related to Intel integrated GPUs. Intel/Apple never got around to fixing it on the Intel Mac driver.



  • What @benfowler said works. Which is mystifying... Anyone has any idea why showing the controls would affect the refresh rate or any other aspect of rendering?

    Also @f-lux-team: have you considered open-sourcing this project? Someone who's affected and with some coding chops might be able to give more debug info and maybe even submit a patch?

    Thanks for the great work and for looking into this issue.



  • @shariffy The bug is not in f.lux, it's in the OS video driver. Open-sourcing would do nothing.


  • f.lux team

    This is correct. Thanks for the offer though.

    @innerbat said:

    @shariffy The bug is not in f.lux, it's in the OS video driver. Open-sourcing would do nothing.



  • @lorna Fair enough. Just a wild thought as this is both a long-standing issue and affecting quite a few users.

    @innerbat I am aware. That said, I doubt Intel and Apple are falling over themselves to fix the issue. My thought was to research how f.lux could detect when the glitch will happen and (offer to) disable itself in those problematic cases. Research which could be easier with access to the code. But thanks for shooting down a benign suggestion within a minute of posting. :) Here's your sticker.



  • just to give an update: I still have the same problem with OSX 10.11.4, Safari 9.1 and flux 36.6. Btw moving the mouse does prevent the artefacts from happening, but who wants to do that all the time in fullscreen right? ;)



  • @lorna any word from the intel guys on this? thanks!



  • This post is deleted!


  • Hello! I'm having the same problem with artefacting, but in quicktime. If a spot in the video is pure white, and the video is playing with the cursor hidden, then white spots are not tinted, rather pure white. You can see when I start playing the video that the colors brighter on the GIF here.

    MacBook Pro late 2013



  • is anything being done about this or should i just uninstall f.lux?



  • This used to be a deal breaker for me too but the workaround suggested by @benfowler is perfect and currently the most convenient way to avoid the issue.


    There is 1 easy hack to avoid this issue.

    Put the mouse curser onto the youtube / netflix video scroll bar at the bottom of the screen.
    The issue seems to arise due to refresh rate at full screen video in safari.
    Possibly to save battery, safari technology doesnt refresh areas of the screen that have pixels the dont change or similar.
    But when you put the curser over this area, , it does seem to solve the issue .



  • @jonsnow When you do that, you are not really in full screen any more, because the video title appears so does the video timeline scroll bar, taking up 10% of the top and 10% of the bottom and adding distractions.



  • I'm experiencing the same issues with fullscreen YouTube videos, I found if you zoom in (cmd, +) it removes/stops the artifacting so you don't need to keep your curser on the timeline blocking some of the video, it doesn't effect the video just makes the playback elements larger. No idea why this works or if it helps with netflix.



  • I'm on MacBook Air 2015 and have the exact same issue, and I found a simple solution:

    Use Firefox at night.



  • Hi all, it has to be issue in Safari. It appears in videos from various web pages. I can't believe Apple is doing nothing with this....



  • Hey all,
    Definitely not just a Safari issue. Having the same problem and can replicate the results in both Safari and Chrome. Admittedly, I have not tried Firefox.

    Running MBP 13" (Early 2015) with the Intel Iris 6100 chipset.
    Chrome ver. 53.0.2785.46 beta (64-bit)
    Safari ver. 9.1.2 (11601.7.7)
    f.lux ver. 37.3

    I've found that, for some reason, this issue doesn't occur when you crank the display scaling in System Preferences to the highest it will go. (1680x1050 on my set up).



  • AAAAH I'm getting MAD!

    I've never had this problem before on my 15" retina MBP mid 2012, but it got stolen (in a fucking brutal home invasion robbery) and now I have a 13" mid 2015 retina MBP that I got from work and these artifacts are KILLING me.

    Those fucking bastards that stole my computer are now also responsible for all GPU problems in the world and I hope they die. Good news for everyone, they're both in custody so send all your fucking lawyers because these guys are gonna get some software engineering training, and hopefully when they get out they will FIX IT.



  • The problem persists! I am using Safari as well. Maybe I'll just get Firefox and see what happens...

    Safari 9.0.1
    El Capitan 10.11.1
    f.lux 37.2



  • Guys! The problem is not with Safari, it's the f.lux app itself! I don't mean to be rude or anything or like that, but it has to be f.lux's fault for this color artefacting because when I disabled it, YouTube videos in fullscreen mode weren't having that issue anymore. All videos ran fine as they're supposed to.



  • @Joegenius98 FYI, I have the latest 2016 MacBook, but that doesn't matter because I tried out the Macbook Air and Pro at the Apple Store and even played 4k videos on Safari without any problem.



  • I'm experiencing this on Netflix also. OSX 10.11.6. I wonder why it's taking the flux team so long to fix this?



  • @mixolyd I'm assuming they don't see the point in patching until OS Sierra gets its public launch. It is getting ridiculous though. Very annoying



  • To everyone: Apple keeps managing color settings and modifying how something as simple as auto brightness adjusts BRIGHTNESS and starts having it also adjust gamma.

    F.lux uses gamma ramps so that's one part of it. Now Mac OS Sierra reads color profiles differently.

    It's almost as if apple is doing the most annoying shit possible to stop the f.lux team... because they want their own version.

    Night Shift for Mac OS will happen. That's Apple for you.



  • @Tungsten_smooth Thanks for letting us know!



  • @Tungsten_smooth well, that sucks because Night Shift doesn't actually take blue all the way out. I find it unuseable on my iPhone without an attachable blue light filter.



  • @thedouglas How do you know?



  • I discovered a workaround. just download this menu-bar app:

    https://gfx.io

    And set your graphics card to the discrete one when you are doing things in fullscreen - it uses a little more battery, but fixes the artefacting.



  • @Plasma_000 yes that will sometimes help but maybe not for everyone. There is already iOS night shift and they basically told them f.lux team to stop--haven't heard anything else about it after that. Just my 2 cents.



  • @thedouglas I don't think you're right about that. Night Shift works the same way as f.lux. It intercepts colors before they're displayed and removes a certain amount of the blue light from it. Neither app is a simple filter, there are algorithms that determine how much blue to remove from each pixel. If you want Night Shift to take out more blue light, turn its intensity up.



  • @evansimk Yes it works but the default is HORRIBLE and many people will just leave it on default or not use it because it doesn't look right and the settings say nothing about the lighting environment.

    Apple doesn't care and the interface is lazy.


  • f.lux team

    @evansimk Night Shift is an extremely gentle copy of a version of f.lux from 2008. It does not remove as much blue light and the default just doesn't do much to help sleep.

    https://fluxometer.com/rainbow/#!id=iPad Pro Night Shift/default
    compared with
    https://fluxometer.com/rainbow/#!id=iPad Pro/1900K-iPad Pro



  • @lorna Is there still no solution to this issue?



  • seems to now be happening with chrome as well.



  • Registered here just because of this phenomenon. It happens to me in Safari and Chrome (haven't tried any other browser). I love flux and would love to be able to use it again.



  • Also registered here to bump up the thread. It's a really annoying issue and needs to be solved ASAP. Or at least give us one straight answer: Are you going to fix this or not? Is anyone working on it or not?



  • Registered just to confirm this.
    I've never thought it would be from f.lux ! it used to be working just fine untill last week for me.
    anyways. hoping to get this fixed. amma disable the shit out of it...can't afford those blue lights anymore !



  • I noticed this happening when watching YouTube fullscreen earlier this week. It just occurred again and it caught on to me that it only glitched when f.lux was in effect. Googling around led me here.

    I only registered and am posting since I just wanted to confirm that the issue is happening and bump this situation up. This is on Chrome 50 for Mac (on MacBook Pro 15" w/ Retina Display Mid-2014 running OS X El Capitan 10.11.6). If I recall correctly; I also updated f.lux recently, so maybe that could be the issue? I don't watch YouTube videos in fullscreen often so it would have flew past me.



  • registered just to bump this thread. I have a macbook pro from 2012 running os x el capitan and youtube has been bugging out quite a bit. Are you guys going to get on this at all?



  • Bumping as well, experienced this issue just moments ago for the first time, after having used Flux for years.

    OS:
    OSX El Capitan, 10.11.6
    Graphics: Intel Iris Pro 1536 MB

    Browser:
    Google Chrome
    Version 53.0.2785.116 (64-bit)

    Strangely, mouse events seem to temporarily mitigate the artifacting, but I assume this is also hardware related.

    On another note, your Facebook registration (and probably login) is broken, because your Facebook app is still in development mode.



  • started happening to me with chrome 53 I think. It is not happening in Safari 10.0, shipped with macos Sierra.. which is the only workaround.

    it may be pita to debug this one, seems like a video driver issue. I suggest contacting chrome devs, they will have someone with the skills to debug/investigate even though this is probably not their fault as well.



  • @gberberoglu Ultimately it's webkit, not "chrome devs".



  • @isaachinman well only safari uses webkit now, chrome runs the fork called blink. and my safari does not have this issue..

    anyhow I've reported this via chrome feedback, but I think it should be more "official", like a f.lux dev opening a ticket to chromium guys.. I'm sure there are some chromium devs using f.lux :)



  • @gberberoglu said:

    started happening to me with chrome 53 I think. It is not happening in Safari 10.0, shipped with macos Sierra.. which is the only workaround.

    it may be pita to debug this one, seems like a video driver issue. I suggest contacting chrome devs, they will have someone with the skills to debug/investigate even though this is probably not their fault as well.

    You don't get this with Safari on Sierra? Interesting. I'm still on El Capitan but I definitely get it with Safari in both youtube and netflix. Looking forward to upgrading to Sierra then



  • @mixolyd try safari tech preview.. it runs side by side, and works on el capitan.. https://developer.apple.com/safari/technology-preview/



  • @gberberoglu @mixolyd Cool, good input.

    As I said in my original comment, the issue is somehow affected by mouse events. Specifically, (for YouTube at least), if you maintain a hover state (eg go fullscreen and hover over the bottom toolbar, keeping it open for the duration) the artifacting doesn't occur.

    That being said, it's a silly workaround. I'm not sure how well-funded Flux is, but it should certainly work with a stable version of Chrome. I've worked with the webkit guys in the past and am happy to help here if someone from Flux can provide some direction.



  • ok now I'm sure that this is a browser thing.. safari used to have the problem but the latest safari works..

    I downloaded chrome 51 just works without any artefacts but latest 53 have this issue.. so I looked at what is different in about:gpu pages.

    you can diff them using an online diff tool.. one of them must be causing this issue.. so I think this is a legit case that f.lux guys can bring up with chromiun devs.



  • @gberberoglu said:

    @isaachinman well only safari uses webkit now, chrome runs the fork called blink. and my safari does not have this issue..

    anyhow I've reported this via chrome feedback, but I think it should be more "official", like a f.lux dev opening a ticket to chromium guys.. I'm sure there are some chromium devs using f.lux :)

    Just updated to Sierra. I'm definitely still having the issue in Safari, at least with Netflix.



  • Hi, i just recently got this issue (and i have being using flux for quite a while now) running videos fullscreen, moving the mouse will stop the pixalate on youtube (only on Chrome, on Safari this issue does not happen, so i don't think this is a Intel issue but a Flux issue) and also in Netflix. any solutions yet?

    MacBook Pro (13-inch, Mid 2012)
    MacOs X 10.11.6
    Intel HD Graphics 4000 1536 MB
    F.lux 37.7



  • found in another forum room by chris-l

    https://chrome.google.com/webstore/detail/videofixer-for-flux/gmkeppffdejhpppfnbgakglpoeaobhhh

    this extension for chrome will fix the issue.