f.lux does not work when switch to iPhone Simulator(any)



  • When enabled 'Sunset' or 'Bedtime' mode it's disabling each time I'm focusing on iPhone Simulators and get back when I focus on any other program.

    Is this a bug or I can use some work-around in this situation?

    Thanks in advance 🙃 😉



  • The most likely reason is that f.lux "disable for app" is set for the simulator. Can you look in the f.lux disable menu to check?

    Or if you want to reset to defaults, you can option-click on the f.lux icon to do that.



  • thanks, that helps me. It was not checked initially, but when I try "Disable->for an hour" it shows me a hidden check-box "Disable->for iphoneSimulator". When I uncheck both - all works as expected.

    🤩 🥳


Log in to reply