Time Logic - a bit off?

  • Deets: 11.5 Intel silicon
    F.lux: 41.5

    So I have my time zone set automatically based on location which is PST. (This has been toggled on/off/etc)

    F.lux is correctly reporting Sunset for 5 hours from now, same goes for the "Wake: X hours ago". Though in order for that to happen, I have to set the "X:XX is when I wake up" for 7 hours later than I actually do. Which is not the worst thing in the world, as I've just manually set it as such. So while I have a work around and it might just work when I move time zones, I have a suspicion it won't. I only noticed this arvo because everything was SUPER "red" and when I popped in, it was like wake in 9 hours, which would be when I would be going to bed.

  • Can you check the timezone here?


    Our "wake time" setting is entirely in local time - and I am not noticing any timezone offset on 11.5.2 here. Could you post a screenshot to show what you're seeing?

  • Apologies on the delayed response. I tried uploading the screenshots, but got a sharp error so imgur'd it.

    Time sync

    Flux settings

  • @polyfluxeus

    Yes this really should not happen! It looks like part of the system is in UTC, but most of the system has a correct timezone.

    Can you do these things from terminal?

    "ls -l /etc/localtime"
    then also "echo $TZ"?

  • All good - no worries. I've worked around it.

    ➜ polyfluxeus~ ls -l /etc/localtime
    lrwxr-xr-x  1 root  wheel  45 24 Aug 17:25 /etc/localtime -> /var/db/timezone/zoneinfo/America/Los_Angeles
    ➜ polyfluxeus~ echo $TZ
    ➜ polyfluxeus~

  • ONLY other thing I could think that might? cause some problems. My region/locale is set to NZ (and would prefer to keep it there.)

    Another Imgur'd link

  • Hmm, looks like they are 5 hours behind (or really, 19 hours ahead). But you are right, the language settings should have no impact on local time. I will email for some more debugging.

Log in to reply