Flux not installing after clean install Yosemite



  • I've been using flux happily for a few years now, but I recently did a clean install on my Mac (OS X 10.10.5 - same OS I previously had), and while reinstalling all my software, I found Flux will not install. At first it gave me the error message "Flux app is damaged and can't be opened". I've tried redownloading, restarting the computer, different ways of unzipping, but the result was the same. I tried again a few days later, and now I don't get the error message, but nothing happens when I double click the unzipped app. It doesn't open, and no icon appears by the clock. I was wondering if the current version of Flux no longer supports my old OS, but I can't see any system requirements information on your web site.



  • Thank you - it appears our automatic updater does not work on Yosemite.

    For now please get this build:

    https://justgetflux.com/mac/FluxLion.zip



  • Thanks, this worked. It is asking me to update though - should I do that? Or will it ruin everything for me?



  • I would stick with v39 for now.

    Hopefully we can get the framework that's broken fixed, because we would like to keep supporting Yosemite officially.



  • Thanks so much!



  • We posted a build (41.2) with a change to the way we sign the app. Seems to be working on 10.10.

    https://justgetflux.com/mac/Flux41.2.zip


Log in to reply