Disable on full screen not working w/ external monitor plugged in



  • Hello fluxers!

    Disable on full screen isn't working for me when I am plugged in to my external monitor. Looks like someone else had this question too:
    https://forum.justgetflux.com/topic/7055/disable-full-screen-not-working-with-multiple-monitors

    Any ideas?

    Thanks for your support!
    Bradley



  • I am also experiencing the same issue here.

    The "Disable for full-screen apps" feature does not work when my MacBook is connected to my external monitor (LG 34UC99-W). Even the feature doesn't work when i go full-screen on my smaller resolution MacBook retina screen.

    However, when i disconnect from my external monitor, the feature to "Disable for full-screen apps" does work on my MacBooks screen.

    Any ideas? Fix?


    Flu.x version: 40.1
    Device: MacBook Air (Retina, 13-inch, 2020, Quad-Core Intel Core i7, Intel Iris Plus Graphics 1536 MB)
    macOS version: Catalina (10.15.4)



  • I noticed that when in Clamshell mode, Flux obeys the enabled preference setting of "Disable for full-screen apps", and so actually disables Flux while the MacBook cover is closed and the external display is in full-screen.

    But really, and ideally, i'd rather Flux is disabled when both displays are active (MacBook and External Display, and not in Clamshell mode), and even better, disabled for either (or both) screen depending on which particular screen is in full-screen mode.

    It's something to take note of.


Log in to reply