Failed upgrade from 36.4 to 36.5



  • Hey there,

    I'm currently running 36.4, and got a notification about upgrading to 36.5. However, attempting to perform that upgrade resulted in an "Update Error!" dialog box appearing.

    "Update Error!" dialog box

    Is there any way I can find out more about why the upgrade failed?

    Possibly relevant: I installed f.lux using Homebrew Cask.

    Thanks!


  • f.lux team

    Thanks for the note about Cask - generally this means that the Sparkle updater could not write the downloaded zip file.

    My suspicion is we're seeing this error when one user downloaded and another is trying to update (and Cask might be running as admin/root?)

    The usual location is here, so please check if this area is writable?
    ~/Library/Application Support/Flux/.Sparkle/



  • I am getting the same error everyday. I've tried updating 4 times now (whenever I'm prompted after rebooting my computer it seems). Each time "Upgrade Failed"



  • Hey @herf. ~/Library/Application Support/Flux is writeable; ~/Library/Application Support/Flux/.Sparkle doesn't exist (although it could be created), and the update process is running through the f.lux app (i.e. I'm not running manual update via Cask, and it's not being run automatically either). The original install (via Cask) was done as my user, not root.


  • f.lux team

    Is your machine a Macbook Pro?

    I'm wondering if f.lux is taking too long to exit and this is messing up the updater.



  • @herf Yes, MacBook Pro (Retina, 15-inch, Late 2013), running El Capitan (10.11.1).


  • f.lux team

    Also, did the update prompt happen at night?

    I think f.lux on a MBP will take longer to exit at night, because it has to reset the system profile.



  • @herf I had one failure at night, but one also during the day.


  • f.lux team

    UPDATE: Amazon is not serving secure enough files for OSX 10.11.1 to install, so it's failing. We're rehoming the download now.


  • f.lux team

    Should be working now.


  • f.lux team

    And thank you for all your assistance with this, it helped us find the problem much faster. Sorry about the error!



  • Great news. Is there any way I can force an update, or do I just have to wait for the auto-updater to kick in in its own time?


  • f.lux team

    You can do this at Terminal and relaunch after:

    defaults delete org.herf.Flux SULastCheckTime

    We have a button in the next version. :)


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.