bug with disable until sunrise



  • flux 39.987 MacOS 10.14.3 (mojave)
    If I use the "Disable Until Sunrise" the following happens.

    1. it is correctly disabled immediately
    2. it ignores the first part of the upward slope (the right side) of the graph in the preferences window and continues to be full white light as expected
    3. at the time when the graph jumps to the far left (new day?) the white light filter kicks in again so it quickly turns reddish and then goes back up to full white light in about 20 minutes. This seems wrong.

    correct until here correct until here

    https://www.dropbox.com/s/bjt0plu93o5fdqi/Screenshot 2019-02-28 05.24.12.png?dl=0

    breaks here breaks here

    https://www.dropbox.com/s/4t3nwwi3a5tojmb/Screenshot 2019-02-28 06.45.33.png?dl=0



  • I have the same issue - I've only noticed it since the clocks changed here last week. I'm wondering if it's expected but perhaps not intuitive behaviour, i.e. 'disable until sunrise' does exactly that, so at sunrise the colour changes back to what it would be at sunrise (not full daylight). What I would want is an option that disables the colour changes until the end of the day (not the beginning). If this is how the option is already meant to work, perhaps the name should be changed!



  • any idea when this might be fixed? It's pretty annoying having to disable flux twice at different times just to get my screen into full day mode in the morning