true tone mac introduces artefacts when flux enabled [fixed in beta 5]

  • Yesterday, I started using flux on a true tone mac (late 2018 13" macbook pro). When flux enabled, black pixels only started introducing artefacts where they would jump to some other color. Taking a screen shot did not show this issue, but taking a photo of my screen shows the issue pretty clearly:


  • I will note parenthetically here, that you can also see that it affects text, looking at the tab text in the browser.

  • Yes, it's confusing that black is overflowing, and apparently only for Intel GPUs in newer Macbook Pros.

    Guess we have to borrow one of these newer machines to see if there's anything we can do.

  • Im having the same issue, but even when i turn tru tone off. ON the new macbook 2018 pro 13" with an i7

  • I've been encountering the same bizarre artifacts, but only when using the internal GPU. Forcing the Mac to use the discrete GPU solves the issue (albeit at the loss of battery life).

  • @herf Happy to test any debug builds or do anything else you need on my end!

  • (Edit: do not need this anymore) Can someone send us a color profile (.icc) from an affected machine?

    We might need to try some hacks like bumping the blacks up to low gray as a workaround if this keeps up.

  • @herf if you can tell me where to find the file, I will happily send it over :)

  • @alexz @theos I have just encountered this "discoloration" issue after a time machine restore. A complete removal of Flux with "CleanApp" resolve the issue.
    Now True tone and Flux are both enabled without any issues.

    I am using a 2018 MBP 13" with an nvidia 1070p egpu setup.

  • We do not have a newer MBP here, so I am posting a test build here to try out:

    This one has a couple experimental fixes, and a new pref called "blackbias" which pushes up the blackpoint to work around the bug


    1. Quit current f.lux
    2. Download/run build above

    3. From Terminal type this into the command line:

    defaults write org.herf.Flux blackbias 0.05

    The default is zero.

    f.lux will reload the setting right away, but you might have to toggle a slider in the UI to make it stick. You can use larger or smaller numbers if needed. I will keep thinking of other workarounds, but this one might be a bandaid until we have a fix from Apple/Intel.

  • And beta 5 has the fix I hope?

  • @herf Hi, I had the same issue as described above on macbook pro 2018. The experimental fix build + defaults write org.herf.Flux blackbias 0.05 seems to solve the issue, except for darkroom mode which still turns the whole screen into bright blue/cyan shade, as it is on the screenshot above.

  • @herf - the experimental fix plus the defaults write org.herf.Flux blackbias 0.1 seems to have fixed the problem. I tried setting it to 0.05 - but I still got the blue overtones (especially when increasing the color temperature).

    Would it be possible to have this be editable via the UI somehow ?

  • Thanks - we will probably not ship this one - it seems to be fixed in the new macOS beta.

  • defaults write org.herf.Flux blackbias 0.05 worked for me!

  • @herf If people are having problems on High Sierra (myself included) there still needs to be a solution developed.

  • Confirming that on 2018 MBP 15":

    • Test-build with defaults write org.herf.Flux blackbias 0.05 worked
    • The issue happens only with Intel GPU, not AMD

    Thanks for the test build.

  • Can confirm that build 39.9871 corrected the cyan blacks issue on a 13" 2018 MacBook Pro (MR9Q2LL) for all Daytime, Sunset and bedtime colors.

    Darkroom mode, however, shifts the entire screen to cyan. Pushing the black bias value to 0.1 did not fix the issue with dark room mode.

  • Late 2018 Macbook 15" here; tried the build 39.9871 and the defaults write ... commands posted above. It largely works, but there are brief periods (< 5 seconds) where black parts of the screen show as bright cyan / bright blue, and then revert back to black. If it helps, I have the Intel UHD Graphics 630 card on this mac.

Log in to reply