Disable Flux for an application not working



  • Recently the option to disable Flux for particular applications is not working. I'm using version 39.94 on MacOS 10.12.5. I can disable it for an hour or until sunrise, but not for a particular application. Is this a known problem? Any suggestions for fixing it?


  • f.lux team

    Please test again with the more recent build (39.983 right now)? https://justgetflux.com/



  • I tried it, and the problem persists. It might be helpful to know that, instead of seeing the option "Disable for Photos" (for example), I first see "Disable for current app," and when I select that option, Flux continues to function, but the menu option is replaced with "Disable for Photos." Selecting this does nothing.



  • Another point:
    When disabling flux for a specific app. Which App name do you use? I noticed a few apps e.g. PDF Expert that are written as "PDF-Expert-Mac" or Mac Blu-Ray Player Pro, written as "MacBluRayPlayer3-Pro". Can you just use the actual title of the app that is displayed in the applications folder?



  • I don't use a name for the app - I just select it from the sub-menu "Disable." I don't see an option to enter the name of the app to disable in.



  • @sdorst This was meant to the developers , not an answer to your question, sorry.


  • f.lux team

    @sdorst Out of curiousity, what are your settings (for color)? And is there any chance you are running Night Shift in the background? The disable feature is working perfectly on my 10.12.5 test machine.



  • @lorna I have f.lux set to start on login, I use custom color settings, I have notifications and backwards alarm clock set, and no color effects selected. The other disable options work fine (for 1 hour, until sunrise, and for full-screen apps) - just the option to disable for specific apps doesn't work. That's a real problem for me because I discover that I have been editing photos with f.lux active, so the colors are wrong!


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.