f.lux beta (another thread)



  • @herf No, version 4.21 installed and no reboot as required. Anyway i did reboot my system before writing those things here, so that's no the problem i guess.



  • Yeah, reboots aren't required for f.lux updates. Fresh installations of f.lux require a reboot though.

    Are you using a USB monitor?


  • f.lux team

    @disqQ Hmm we only use this transform when everything else has failed. That's usually when you have a device attached (like a docking station with USB/DisplayLink) that doesn't work another way. There might be bugs in the way we test the system though, so any more information about your configuration (GPUs and drivers and monitors and how they're connected) that would help.



  • @herf I have a GTX 1070 with drivers version 381.65. Using Dell P2414H with displayport.



  • @disqQ said in f.lux beta (another thread for 4.21):

    @herf I have a GTX 1070 with drivers version 381.65. Using Dell P2414H with displayport.

    Is this with Windows 10's Creator's Update too? I have seen several reports of problems since it came out, and each one was display-related in one way or another.



  • Yes, i'm using Windows 10 version 1703, build 15063.138.



  • @disqQ said in f.lux beta (another thread for 4.21):

    Yes, i'm using Windows 10 version 1703, build 15063.138.

    I thought so. :( Here we have yet another case of the Creator's Update causing problems.

    For the record, I have Windows 7. I'd bet though that I'd probably be experiencing some display-related problem too if I had Windows 10 and the Creator's Update. It seems that's pretty normal so far.


  • f.lux team

    Our NVIDIA (Kepler) machine is still on Anniversary (for displaylink testing) so I will try to make a build that prints out some internal state for you.



  • Thank you.



  • @TwoCables Thanks man, i didn´t know that. But...you are really a Vampire because 800k its too "bloody-style" :D
    PS: Im using 6500k during the day and have enable "reduce eyestrain" but i wonder if this option maintains during nighttime or it will disable itself.



  • @sitayi2308 said in f.lux beta (another thread for 4.21):

    @TwoCables Thanks man, i didn´t know that. But...you are really a Vampire because 800k its too "bloody-style" :D
    PS: Im using 6500k during the day and have enable "reduce eyestrain" but i wonder if this option maintains during nighttime or it will disable itself.

    I like 800K because I want to reduce all blue light when I want to get sleepy, not just most of it. It may look extremely red to you, but when I've been awake for a very long time, it's an extremely welcome thing and it no longer looks all that red (especially when there's no daylight coming through my window). I also switch to just one of these lights and nothing else:

    http://www.feit.com/led-lamps/performance/performance_led/performance_led/color_leds/color_led/a19-r-led

    When I'm maybe 30 minutes away from bedtime, I switch to this little thing:

    https://www.amazon.com/Westinghouse-03469-Nanolux-1-Watt-Bulb/dp/B000UQ1Y0Y

    If you're serious about your sleep, you get serious about everything that affects it. When I've been awake for a long time and I want to go to sleep in a couple of hours, it feels extremely good to go to 100% red light. Going from 6500K and a bright monitor to 800K and red indoor lighting and also a very dim monitor is a huge relief when I've been awake long enough to be extra sensitive to light.

    Check the curvy lines in f.lux to see how sensitive to light you're most likely to be when you've been awake for about 14-16 hours.



  • @TwoCables Man...you are amazing! Many thanks, im learning a lot with you!
    Ive been using F.lux since 2010 and can´t live without it anymore.



  • @sitayi2308 said in f.lux beta (another thread for 4.21):

    @TwoCables Man...you are amazing! Many thanks, im learning a lot with you!
    Ive been using F.lux since 2010 and can´t live without it anymore.

    You're quite welcome!

    Yeah, I think I've been using f.lux since maybe 2011. It's absolutely wonderful that I can still use my computer when I have successfully reduced or eliminated blue light and alerting light everywhere else in my little living space!

    Of course, I don't think it ends with light (or the brightness of light). I think it's also good to avoid loud noises and sounds, fast rhythms from anything, video games, movies, pretty much anything on T.V. these days including the news (heh), physical activity that raises your heart rate and gets you going, etc. Anything that is stimulating and energizing can be bad and make it harder to go to sleep. I mean, I think we should all take a cue from the animals outside because when the sunset draws near, they begin winding down and their activity levels decrease and they make less noise, etc. They calm themselves down and avoid things that interrupt that calm serenity they are trying to achieve.

    I even found in my research that it's best to wait a minimum of about 3 hours after eating before going to sleep because that's about the minimum amount of time for your stomach to become empty so that your body isn't being forced to digest while you are trying to sleep. Have you ever gone to sleep like say 30 minutes or an hour or an hour and a half after a decent-sized meal only to wake up hot or to have bad dreams - or both? Or you think you sleep fine but you feel kinda crappy the next day?

    Then, of course, there's caffeine and alcohol and other things. lol

    Of course, at 800K, there isn't much I can do on my computer and still enjoy it except for maybe reading things. That's fine though because I really shouldn't be doing anything other than super calm and peaceful things at that time anyway. Still, it's hard. I want to play video games or something so that the time goes by faster so that before I know it, I'm laying down to go to sleep. lol

    It's tough being a human being on this planet. LOL :)



  • On Windows, where is the disabled-program data stored? Since, currently there is no option to un-disable the use of f.lux with a certain program once it's been disabled for that program already.


  • f.lux team

    @SomeGuyNamedDavid Undo it the same way - open the program you want re-enabled, then open f.lux preferences > uncheck disable for [current app]. No master list yet.


  • f.lux team

    Before I update everyone, look at 4.22?

    https://justgetflux.com/flux-setup4-22.exe

    This one is all about color - we are trying to dial in better color calibrations even when Windows doesn't have one. Basically a lot of our laptops were too "green/yellow" and we tried to fix it using some embedded monitor info.

    Also trying to fix tone map so things look better when you dim a lot at night - looks amazing when it works.

    Color stuff may be buggy, so let me know! Options has "Use Monitor Data for Calibration" which you can turn off.



  • @herf Well....colors are more darker indeed :D can you explain what "Use Monitor Data for Calibration" means? I see little difference when I turn it off.


  • f.lux team

    @sitayi2308 Well most monitors have a built-in record of their chromaticities (the exact colors that RGB are).

    It used to be, this wasn't a good place to look for information, but with the half-dozen machines around here, we found awful color profiles but perfect embedded panel profiles. So we turned this on, and for some of our machines it is dialing in perfect colors.

    "dUV" is "distance from the planckian locus", or how far a thing is off the blackbody curve. So we had one particular laptop that was dialing in +0.016 dUV (way into the green/yellow area), and now it is around -0.001. So you would call it a beautiful warm glow, rather than puke yellow!



  • indeed darker color, Halogen turned Incandescent (Benq xl2730z)

    my feedback:

    1. can you please add an option for disable the Notifications on hotkeys actions? (alt page down, etc) In Overwatch when i change brightness the notification makes the game minimize and send me to desktop

    2. If i'm seeing it right each step on brightness is 7%, can it be a option to set how much % we want to each step ? I prefer small steps (on of the good things that SunsetScreen has) because this monitor brightness is weird (too dark or burn your eyes)

    thanks for the work !



  • Whoa. I think Alt+Page Down dimming looks much better. I mean, correct me if I'm wrong, but I think that previously dimming resulted in a severe gamma shift effect whereas now it's much more even from the top to the bottom of my monitor.

    I've been meaning to say that I think it would be great if f.lux could remember my last Alt+Page Down dimming setting. That way, if I restart my computer or exit f.lux and then relaunch it, it will go right back to where I had it. I always dim 1 or 2 increments when I go to an extremely warm red color like 800K because dimming with Alt+Page Down restores proper contrast at these extremely red colors with my preferred NVIDIA Control Panel "Digital Vibrance" setting. Obviously I could just stop using Digital Vibrance when I go to a very warm color like 800K, but it takes far more time than just pressing Alt+Page Down and the result is the same.

    I'd even say the Alt+Page Down dimming should never be undone unless the user chooses to do so, even if the computer is restarted (or if f.lux is closed and relaunched). So, I would even go as far as saying the dimming setting should always remain until the user restores the brightness with Alt+Page Up. After all, there is a "Return to Full Brightness" menu item now. Right now, the dimming is undone way too easily. It happens when I disable f.lux too.

    I think it would be nice too if we had the ability to dim from the f.lux menu or the window too. I think it would need to be a slider. Or, at least arrow buttons to click. Or, maybe just a drop-down menu of the different dimming levels. Or a sub-menu. Or both. Or all of these.

    I noticed too that Darkroom Mode gets disabled if I Alt+Page Up at all while in Darkroom Mode regardless of where my dimming is currently set. I don't know how long it has been like this though; this is the first time I think I've pressed Alt+Page Up while in Darkroom Mode. I would say that this isn't desirable. Of course, I could look at it as an easy way to disable Darkroom Mode. heh :)

    All transitions are now only super choppy if the f.lux window isn't open. So, all transitions are very close to being butter-smooth when the f.lux window is open, but once it closes (or if I close it), they become a slide-show every time I have a transition.

    I think the transition speed when launching f.lux to the set color temperature (like 800K for me) should be much faster. The transition speed for disabling and re-enabling is wonderfully fast, so I'd like it if the transition on the launch of f.lux (or when restarting the computer) could be that fast or faster.

    I think a restart is required after upgrading to 4.22. Before I restarted my computer, I was able to break the "Disable for [program]" feature by doing this:

    1. Enable "Disable for [program]" (in this example, I am using Firefox)
    2. Switch to Firefox to disable f.lux
    3. Open the f.lux window (f.lux remains disabled at this point)
    4. Go into the f.lux menu using the f.lux window and turn off the "Disable for [program]" feature

    When doing this, f.lux would get stuck at 6500K because it was still disabled for that program while I turned the feature off. After that, the feature no longer worked, even if I closed all programs and exited f.lux and reopened everything. Apparently, I had to restart my computer to fix it because I can't break it anymore no matter how hard I try.

    Before restarting my computer, I was able to Alt+Page Up in Darkroom Mode without disabling Darkroom Mode. Now it disables it.

    I don't know how to reliably reproduce this next bug, but sometimes the percentage of daylight will read 0% when I choose 1200K, and sometimes it will read 1%. Sometimes it seems to depend on how I chose the previous color temperature, whether that's via the menu or via the slider. Sometimes it seems to depend on whether I had 6500K selected prior to choosing 1200K, sometimes it doesn't. It's strange. If it reads 1% at 1200K, I can get it to go to 0% and stay there by Alt+Page Down dimming, and then Alt+Page Up to restore the brightness. Note: I am using the Very Fast transition speed, if it makes any difference.



  • So to add, I think a restart should be required for this update. Version 4.22 is working noticeably better for me after restarting my computer. When I installed 4.22, I still had 4.21 installed - but it wasn't running of course. I always exit f.lux first. So, it's not like I had a fresh installation of 4.22.



  • @TwoCables So far the only difference is more yellowish in all settings, so i presume thats the correct color when "Use Monitor Data for Calibration" its activated.



  • @sitayi2308 said in f.lux beta (another thread for 4.21):

    @TwoCables So far the only difference is more yellowish in all settings, so i presume thats the correct color when "Use Monitor Data for Calibration" its activated.

    I have no idea. That setting isn't changing anything for me.


  • f.lux team

    @TwoCables we turn it off internally when the monitor doesn't give good data or just reports sRGB. Probably should hide the checkbox then too.


  • f.lux team

    @TwoCables whether it says 1% or 0% is probably due to dimming - it should not care how you got there. And we aren't confident about these numbers to this level yet anyway!



  • @herf said in f.lux beta (another thread for 4.21):

    @TwoCables whether it says 1% or 0% is probably due to dimming - it should not care how you got there. And we aren't confident about these numbers to this level yet anyway!

    It's not due to dimming.



  • @lorna Bringing up the f.lux right-click menu while the program is launched doesn't show any disable options after the program has already been disabled.

    Though, on a separate note, I'd also like to see more options for how f.lux handles disabling-by-program. Currently, f.lux re-dims the color temperature as soon as the program window in question loses focus. Meaning that clicking in/out of the window frequently results in lots of temperature shifting. Either an option for "disable f.lux for out-of-focus programs" or a time-out period for f.lux's re-enabling (e.g. f.lux will wait 5 minutes after losing sight of the program before turning back on) would be great to see.



  • @SomeGuyNamedDavid said in f.lux beta (another thread for 4.21):

    @lorna Bringing up the f.lux right-click menu while the program is launched doesn't show any disable options after the program has already been disabled.

    Though, on a separate note, I'd also like to see more options for how f.lux handles disabling-by-program. Currently, f.lux re-dims the color temperature as soon as the program window in question loses focus. Meaning that clicking in/out of the window frequently results in lots of temperature shifting. Either an option for "disable f.lux for out-of-focus programs" or a time-out period for f.lux's re-enabling (e.g. f.lux will wait 5 minutes after losing sight of the program before turning back on) would be great to see.

    To put the disabled program back in the list, put it in focus and then open the f.lux menu or window. Then you can undo the disabling.



  • @TwoCables Alright, that worked, thanks. (Extremely prompt response, too!) There were difficulties in doing so because the window in question was in bordered fullscreen, meaning that the only way to get f.lux to see it was to open the f.lux window, click into the program in question, and tab back into the f.lux window before it closes. However, strangely, this method only works sometimes, rather than all of the time, so I may have to attempt it several times before the program in question will appear in f.lux's menu.

    Also strangely, the program in question appears in f.lux's menu twice when it does appear. Clicking the first one places/removes checkmarks on both, while clicking the second one does nothing.

    In the future, it might be better to have disable-able programs persist in f.lux's menu for a minute or so after they've been in focus, or to show the last few most recently in-focus programs in said menu, to prevent possible issues like these.



  • After what Lorna said in the post below, it sounds like they do have plans to make it far better.

    https://forum.justgetflux.com/post/13405

    "No master list yet."


  • f.lux team

    Yes this is still a work in progress. We held off on the feature in v3 because we didn't like the timing, which still needs improvement.

    I think we did a little better with the timing on Mac, where disable is very fast, but re-enable is very slow. The case for me is: working in Photoshop (disabled), alt-tab to a chat client (enable slowly), go back to Photoshop. Fast adjustments back and forth are not very good here.



  • @herf Alright, sounds great, will be looking forward to it. Keep up the good work, been loving much of the new beta changes so far.


  • f.lux team

    @SomeGuyNamedDavid Not while it's launched, while it's active. Thanks @TwoCables for making that more clear.



  • @lorna said in f.lux beta (another thread for 4.21):

    @SomeGuyNamedDavid Not while it's launched, while it's active. Thanks @TwoCables for making that more clear.

    You're welcome, Lorna.



  • 4.21 on my Laptop (Windows 10) the location is incorrectly showing Europe Asia even though the LAT/LON it's showing is actually the North of England.

    I know we're going through Brexit and everything but I don't recall England becoming part of Asia ;-)


  • f.lux team

    @dragon2611 Wow, ok (also thanks for the giggle). Can you message me your coordinates or send a screenshot? Does Google maps locate you correctly?



  • Since this new update and turning the "Use Monitor Data for Calibration" ON in whatever setting i use (2700k 3400k etc) its more yellowish, it will take time to get used to it. So I assume that it due to my laptop screen calbration....


  • f.lux team

    @sitayi2308 maybe we should make a visualizer for it :) which laptop do you have?





  • @herf A humble ASUS X555L


  • f.lux team

    Fixed another color bug, sorry!
    https://justgetflux.com/flux-setup4-23.exe



  • @lorna Right, it's just difficult to reach f.lux while the window is still active if it's fullscreened, because bringing up the taskbar to get to f.lux deactivates the window in question.

    A totally separate thing to note is that f.lux also seems to be creating multiple entries in the "hide/show taskbar icons" settings, depending on what time it is. So my list contains items like:

    • f.lux
      Sunset: 4 hours ago, Wake in 9 hours
    • f.lux
      Sunset in 43 minutes, Wake: 11 hours ago
    • f.lux
      Sunset in 13 minutes, Wake: 11 hours ago
    • f.lux
      Sunrise in 5 hours, Wake in 7 hours

    which are continuously appearing, and must all be turned on/off in order to consistently show/hide f.lux in the taskbar, else it will appear and disappear as time passes.



  • I'd like to see the ability to use the color-changing keyboard shortcut to go back to 6500K from 800K. Right now, I can get close but it's either 6300K or 6550K.

    Transitions while the f.lux window is closed are very choppy for me. When the window is open, they're fairly smooth.

    I think that radio buttons should be used on menu items that can't be deselected when clicking them again. Check marks make it feel like I can just click the currently-selected item to deselect it.

    When I have f.lux disabled for a specific program, or for an hour, or until sunrise, I think it would be nice if it would say so in the window instead of just "Disabled".

    If I'm using custom colors and I go and select a different preset like "Recommended Colors" or something, I would love the ability to instantly go back to my Custom Colors by having a menu item by that name to choose from in the drop-down menu.

    I'm not sure if it's supposed to be automatically updating, but it's not.

    The download link in the beta thread (https://forum.justgetflux.com/topic/3675/f-lux-beta-for-windows) isn't for 4.23 either.

    I found a weird bug. Here's how to reproduce it:

    1. Put f.lux in Bedtime mode
    2. Choose a color that's warmer than 6500K for either Daytime or Nighttime, depending on the underlying mode that f.lux is in.
    3. Hold down CTRL and try to get Bedtime mode to be in 6500K.

    What you should find is, you can only go as high as 6450K. As soon as you put the slider in the 6500K position, the set color temperature drops down to the warmer color for Daytime or Nighttime that you chose, but the slider stays in the 6500K position. It only does this for Bedtime mode. If you release the slider button by releasing your mouse button, the color temperature will drop down as depicted.

    I think it would be nice to choose how long the f.lux window stays open for when it's not in focus.

    I think Movie Mode should be forced on if you choose it while your current color temperature is higher than 4400K.

    I might have more to post later.


  • f.lux team

    Posting 4.24 which avoids interrupting fullscreen apps with notifiers and popups, so at least we can use hotkeys to debug these cases.

    https://justgetflux.com/flux-setup4-24.exe



  • I found that having the monitor data for color calibration ON, (im using 2700k) the screen is yellowish....i dont like very much, so if i disable it it goes to f.lux default color right?



  • 2700K is supposed to be yellowish.


  • f.lux team

    @sitayi2308 yes it goes back to the old code instead



  • @TwoCables Actually it was more red...but i will get used to it. BTW, nice job Herf and Lorna.



  • 4.24 still thinks I'm in Europe, Asia same as screenshot posted earlier for 4.21


  • f.lux team

    @dragon2611 We are using the windows location service. Can you run the "Maps" app from Windows and see if it is doing the same thing?