El Capitan: Disabling is buggy



  • As of El Capitan, the disable button doesn't always work right the first time. The screen dims, but flux doesn't actually deactivate. Then when I click the button again, it does deactivate, but it instantaneously goes back to full brightness when doing so, and the disable button is now unchecked because I clicked it twice. So then I have to click it one or two more times to have it be disabled and actually say it's disabled.



  • I am having a similarr preoblem. The "Disable > for an hour" option seems to be broken.

    This did not heppen before I upgraded to El Capitan. Now disable for an hour does not work when I click it.

    The only workarround I have found is to quit f.lux and reopen it. Only then will disable work.


  • f.lux team

    Do you have auto brightness on?
    Do you have a dual GPU machine?



  • My experience is was exactly the same as @Matthew's. While writing this, I got the bright idea to re-download the app. I was on 36.3, and the download was 36.4. It appears to be working as-expected now. My original post below…


    "Disable > For an hour" worked perfectly in Yosemite. I upgraded to 10.11.1 and it no longer does anything. I have to quit f.lux to disable it.

    Additionally, for apps that automatically disable f.lux (Photoshop), it sometimes turns off when switching over to that app, and fades back on when switching away. Sometimes, it just stays on. If I switch to Photoshop and it stays on, then ⌘+Q to quit Photoshop, it will go off and immediately fade back on. Very odd…

    I have auto-brightness on (but if I recall correctly, that works slightly differently on older Macs like mine…), and a single GPU. I'm using f.lux 36.3


  • f.lux team

    I just pushed 36.4 as an automatic update, so hopefully it will help some people.



  • @herf Seems to have worked so far, as I haven't noticed any problems with disabling since the update was released.



  • For me is the same... but disable for an hour seems to work. I'm already in 36.4 version.



  • Just updated to el capitan and I'm having the same problem. I updated the version and it worked a bit better but didn't seem to fully go away. Interestingly the screen has redeemed even after quitting the program.


  • f.lux team

    I put some more notes in this other thread...

    tl;dr: it seems like Apple managed to make everything work on a couple models, and on some others the auto-brightness stuff is conflicting with f.lux.

    On our machines, disabling auto-brightness (possibly including a reboot) always fixes things.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.