Build 37.5 & 37.6: "disable for VLC" et al. stopped working



  • v37.4 was fine, but now with the versions v37.5 and higher, the setting "disable for VLC" doesn't work anymore. When I choose that option, then f.lux is disabled at first for VLC, as it should be, but as soon as I switch from VLC to another app and back to VLC, it doesn't remember the setting, and f.lux night settings stay enabled. The same is true for other apps like Safari. So the only thing I can do is choose "disable for an hour", which btw is way too short for watching a film… 90–120 minutes plus. (Did anyone ever think about that?!) Furthermore, the transition between f.lux disabled and enabled is not smooth as before, but very abruptly… even had a short flicker once. Something is seriously wrong with v37.5 & v37.6. Would love to have a link to the old version until this is fixed.

    MBP mid-2010, running exclusively on the Intel built-in HD Graphics GPU; OS X 10.11.6.

    Other installations that might be relevant: Menu Eclipse, HazeOver, gfxCardStatus (set to "Integrated Only")



  • Every other previous version was working just fine. F.lux 37.5 ignores the "Disable for" any of my apps; though it sometimes works on the initial start on the app, but as soon I switch to another app and back it stops working. The setting is correct and doesn't change. Reinstalling F.lux, restarting of Mac didn't help. Furthermore, the change between active and disabled state of this version is abrupt. Previous versions had a smooth transition in both directions, activating and inactivating F.lux, now its instantaneous.

    System information:
    iMac 20" Mid 2007, Mac OS "El Capitan" 10.11.6, ATI Radeon HD 2400 XT 128 MB



  • In my case it doesn't even work on the initial start of the app. I have to start the app first, and f.lux stays in night mode… then select "disable for app", but there's no use in doing so anyway, because f.lux will forget as soon as I switch to a different app. It's basically broken.

    Reboot didn't work either here.


  • f.lux team

    Hey everyone - we posted this build which fixes the disable bug - let us know if it helps?

    https://justgetflux.com/mac/Flux37.7.zip

    Michael



  • @herf It seems to work on my system. VLC<>other back-and-forth works, and transitions are now smooth again. Thank you for the fast bug fix!


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.