v37.2: Falling back to night mode when changing monitors over night



  • Hi,

    since the update to v37.2 I see a strange behavior when changing screens over night. Sometimes I work late in the office where I have an external screen connected to my MacBook and change to home over night (to get some sleep) where I don't have the external screen. What happens in this scenario is, that the internal screen stays in bedtime mode, even if flux is shut down. What I can reproduce now is the following:

    1. Work that late, that flux goes into bedtime mode while having the external screen connected.
    2. Put your laptop into standby (by closing the lid)
    3. Wake up your laptop at day time without the external screen attached

    Result: Flux falls back to the bedtime profile after wakeup, even if it shows the dot being at the right time of day in the preferences dialog. When quitting flux, the screen stays yellow and only a manual switch of the color profile in the system preferences brings it back to daylight settings.
    Restarting flux falls back to bedtime mode. If the flux color profiles still exist, flux jumps bedtime mode (at daytime!) right at startup. When I delete the flux color profiles, it takes a few seconds after flux startup to fall to bedtime mode.

    I haven't found a reliable solution to get flux back to work. Sometimes I find the right trigger, but sometimes I have to shut off flux for the rest of the day.

    Btw: The described behavior can sometimes also be observed when I leave the laptop in the office over night, so waking it up in the same monitor configuration the next day. When it happens there, usually restarting flux solves the problem.

    I this a known bug, possibly with an already existing workaround?

    Cheers,
    Christoph


  • f.lux team

    Yes, it's a bug in automatic brightness. We can't work around it without using 100x the normal CPU - the previous f.lux build believed it was constantly "fixing" a broken profile, which it tried to do twice per second.

    There also seems to be an issue with AMD Radeon cards, but we're not sure what it is yet.

    Some questions:

    • Which model Macbook do you have? Apple > About This Mac... and the Graphics card too?
    • If you turn off automatic brightness and reboot, does that help? (If it's on already.)


  • Sorry for the late response. The notification mail was sucked up by my spam filter.

    Back to topic: I'm using a MacBook Pro from mid 2012 with a normal display (no retina), 15 inch. That is a model with two graphics cards. The integrated Intel HD Graphics 4000 and the dedicated NVIDIA GeForce GT 650M with 1GB video RAM.

    Right now, I'm on a business trip till end of next week. So I can't check for disabling the automatic brightness currently. I will deliver this information when being back in the office.



  • I have the same exact hardware and am experiencing the same problem. It seemed like it didn't start doing it until several weeks ago, so I'm not sure if there was an update to Flux that started causing it or what.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.