37.2 acting wonky with fullscreen apps on El Capitan



  • f.lux always had problems with fullscreen apps, mainly games that have their own gamma/brightness sliders. In the past a game and f.lux would conflict, trying to override each other but changing settings in a game would make it stop.

    The problem I have today is this: It's daytime. No fullscreen app is running. f.lux is on. But for some reason my gamma is set up high, as if desktop inherited game's gamma setting.

    If I turn on/off a color screen effect it's fixed. For a while. If I quit and reopen f.lux it's fixed. For a while. But I don't know how to make it stop messing with my gamma permanently, especially since I do graphic design work.


  • f.lux team

    Thanks for your note @Eames. Can you tell me some of the apps you're seeing this on? Feel free to send me a chat as well if you prefer.



  • Namely Heroes Of The Storm, but I remember it happening with others games too: Starcraft 2, Team Fortress 2, CS:GO.

    No idea how how to use chat here.



  • Update: now it also started showing nighttime colors during the day and even quitting f.lux fixes it only temporarily.



  • Something like this is happening to me too. When I start Steam, everything is okay. Then, when I start Insurgency (that is the title of the game in question) the screen goes back to normal (i.e. flux not working). This only means I can't play games at night, because Flux doesn't work during gameplay.

    I have tried a lot of things after google searches. E.g. change brightness before launching game. I tried many settings there, including brightest the screen can go. Another e.g., the ICC change where they have me do a "write defaults" etc. (even though it's an old iMac with only one GPU). I also tried to play the game in windowed mode. In many cases I tried to keep manually selecting the color profile and/or opening Flux settings to move the slider. Any time I go back to the game, the screen goes back to being the normal colors.

    This only seemed to start after the latest update. Is there a way I can get the old version, maybe?

    Thanks in advance.

    V/r,
    Bryan



  • You can get older versions here: https://software.com/mac/apps/flux-1/37.1


  • f.lux team

    @bryanlharris

    Have you turned off autobrightness and rebooted? Apologies for asking but on mobie I cannot see the entire thread easily at the moment. We would love to find a way to fix this for you.



  • What is autobrightness?


  • f.lux team

    @Eames System Preferences > Displays > Automatically adjust brightness - try turning this off and see if it helps. Might need a reboot.



  • Yes thanks Iorna. I had to do both things: disable auto-brightness & reboot. One or the other by itself did not do the trick.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.