Can't remove f.lux from macbook pro



  • Re: Can't remove f.lux

    I installed f.lux a few months ago and found that it just wasn't something that worked for me; the color changes were way too distracting, and I need my screen to consistently be the same color for making art (suppose I should have seen that coming)

    So I tried to remove it. I quit f.lux up on the task bar by the clock, and then went Finder and deleted it from the apps folder, and thought I was done. But when I restart or log into my computer, f.lux still turns on, and the app icon still shows in Launchpad. It doesn't show in the apps folder though, and for whatever reason I can't drag it to the trashcan from Launchpad, even when I quit the program using the taskbar icon.

    Help?


  • Android

    Deleting the application from the Applications folder doesn't remove it completely. I think you have to use the PKG Installer file to remove it. I don't have access to a Mac right now so I can't remember how to do it all. But check in these directories just to make sure that the f.lux application doesn't exist there also;

    /usr/share/bin/
    /usr/share/sbin/
    /usr/sbin/
    /usr/bin/
    /var/opt/local/
    

    I think those are the most likely directories it will probably be installed to, but you will require root permissions to delete the application from either of those directories. But be careful when deleting things as root as you may damage the system and ensure you got the right paths to the file you want to delete.

    use this as a reference example when deleting something as root with Terminal app;

    $ sudo rm -rvf /usr/bin/flux
    

    ($) represents the shell for normal user level, don't actually type that just type what follows after that. (sudo) command is Super Do, which temporarily elevates your permissions to root level NOTE: when using sudo it will ask for password, but will not print to terminal screen as you type it, this is normal for security reasons. (rm) command removes files and directories, followed by the option flags (-rvf) -r flag removes files and folders recursively. -v flag gives verbose output. -f flag forces removal without prompt (assumes YES argument passed for deleting the file or folder). Typing in the full correct and proper paths is essential otherwise you will remove things you shouldn't.



  • Ok, so double checking here to be sure I understood correctly (I have basically no computer skills beyond normal usage and basic troubleshooting, so this is out of my depth a bit)

    I need to go to terminal and type "sudo rm -rvf /usr/bin/flux" and substitute those first 5 directories for the "/usr/bin" part?
    So, "sudo rm -rvf /usr/share/bin/flux" or "sudo rm -rvf /usr/share/sbin/" for example would be what I type in.

    Does that look right? Or should I get somebody who knows what they're doing to help me out rather than trying this myself?



  • F.lux doesn't install anything in any of those folders. Deleting it from Applications and emptying the Trash should be all that's necessary. Stay the hell away from "sudo rm -rf"!!

    If it's actually running, i.e. you get the icon and menu in the menu bar (what you called the task bar), the application must still be around somewhere. You can try several things to find it:

    • do a Finder search for Flux.app
    • open System Preferences, Users & Groups, and look in Login Items. If you see Flux there, right-click on it and choose Reveal in Finder.
    • open Activity Monitor, select Flux in the list, and click the Info button in the top left. Click the Open Files and Ports tab, and see where it says Flux.app is.

  • Android

    @Sabriel415 that is correct, but seeing as you don't have much computer skill I would recommend searching for those files first with Finder, just enter it into the path bar to navigate to those directores in Finder to go to that directory to check if that's where flux is at.



  • And hey, thanks so much for the quick and through response.



  • @Elhem-Enohpi I had already done a Finder search, and nothing came up, but looking in the system preferences seems to have done it. Thanks a ton!



  • @Sabriel415 Where was it?



  • @Elhem-Enohpi Some sort of alternative applications folder, it looked like. It wasnt in the main, normal one that most apps were in, but a different one (still named applications) that had some other applications I had installed but couldnt find. Not sure why they weren't in the normal apps folder, but hey.



  • @Sabriel415 Sounds like the Applications folder inside your home folder? Weird that it wouldn't show up in a Finder search. Anyway, that should do it, glad I could help!



  • Yeah, I couldn't tell you. Times like this make me wish I knew more about computers, because I am really curious why these things happen.

    But anyway, thank you so much! Im glad I was able to get this resolved without having to use terminal. That always make me nervous.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.