'Disable for [app]' not working at all times El Capitan



  • Sometimes I'm switching from one app to another (one of these being an app I had previously disabled in f.lux) and then suddenly f.lux stops disabling the filter. Has it ever occurred to anyone?

    If I wait for it to disable, nothing happens. In fact, I've done this with the f.lux preferences window open and visible in the background. So I've noticed that when I switch to the app for which it's supposed to disable the filter, the temperature in the preferences window changes back to 6500, but nothing really happens to the filter. I can wait for minutes and nothing happens, even though it says "6500 K" in the preferences window.
    If I then switch to another app, the filter finally starts working again, but since it was set to 6500 K, it jumps straight to that super bright white and starts dimming (as I'm now on an app that's not disabled in f.lux)

    I'm using the latest version (36.6) of f.lux, El Capitan 10.11.3 and the only options I have turned on are "sleep in on weekends" and "OS X Dark Theme at sunset". I have tried enabling the other options and seeing if it would work, but... nope.



  • Yes, I get something very similar, but with the 'disable for an hour' feature as well as the 'disable for app' feature, both of which I used a lot because I work with visual arts and have to be able to see real colour values. F.lux tells me it's disabled, but the light filter doesn't change. I then have to 'reset flux', going back and disabling it for an hour before the filter has time to kick in again. Very annoying...



  • I get the opposite behavior - it works ( accidentally chose disable for Safari) but then I cant unset it - the ability to re-enable for that app is gone. Now flux is stuck on bright whenever I'm in my browser.



  • @raj.seshadri You need to have the app, i.e. Safari, running, and in the foreground, to see the option to enable or disable f.lux for it. For example if you're in the Finder, you won't see the option for Safari. Does that help?


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.