Get f.lux to work on external display in OSX



  • I am running OSX 10.11.1 on MacBook Pro (Retina, 15-inch, Late 2013). f.lux v 36.5. I am connecting a DELL monitor(P2212H) using Thunderbolt to VGA adaptor.
    In the System Preferences -> Displays, Dell monitor shows its using Generic Color Profile. I can't find f.lux to work with external display. Tried searching in the forums, but can't find a solution. Is there a way to get it working?



  • @Chetan-Sachdev Noticed another thing, when I open the Displays option and go to "Colors" tab, f.lux settings get applied on the external monitor for the moment. And when I toggle between applications, settings goes off.



  • Oh, please, introduce this solution! I really need it since I am going to buy an external monitor!



  • F.lux works perfectly for me (except for "dimming") on a MacBook Air with an HP external monitor, using a Thunderbolt to DVI adapter, on OS X 10.11.1. It works either with the MacBook's lid open or closed.

    I don't know if it has anything to do with your problem, but you should consider using a DVI adapter instead of VGA, you'll get a better picture.

    If you have the MacBook open, do you see f.lux working on the internal display, but not on the external one?



  • You can do it manually. Just go into preferences >> displays and change the color profile on the external to flux. Done



  • I'm having the same issue. Here are the details:

    I'm using two external monitors with my 2010 MacBook Pro 15"

    One monitor runs off the DisplayPort to VGA adapter, and it runs f.lux properly.

    The other runs off an external DVI video adapter. It plugs into the Mac using USB (it says to use 3 but the Mac has 2 - the display works regardless). To use this adapter, I had to install DisplayLink software. The adapter feeds a VGA cable, like the other monitor does. This monitor does NOT run f.lux.

    Both monitors are ViewSonics.

    I have never had to set the f.lux profile in Display System Preferences for it to work on the Mac's screen as well as the first ViewSonic.



  • @Luigi Please don't post the same message in multiple different threads/topics.



  • @Elhem-Enohpi Sorry about that.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.