Screen changes back from 4200k to 6500k



  • Macbook Pro Retina, OS X10.10

    I have F.lux set up for 4200k at sunset, which it does fine, but when I change between programs or even click on the desktop, the screen goes back up to 6500k automatically.

    Any ideas please?

    M.



  • @malclilley said:

    or even click on the desktop, the screen goes back up to 6500k automatically.

    That's extremely odd. So when you click on your desktop the screen goes back to default? Does it stay there, and also does it go back when you let go of the mouse button?



  • Hi timpster,

    It stays at default 6500k, unless I reset it.

    This is strange and I'm still trying to figure it out. I'm running F.lux on a Macbook Air, same OS, and I can't duplicate the problem on that machine.

    I only put it on the Pro a couple of days ago, while setting it up. So I've only just noticed it. I uninstalled it and reinstalled it just to check the download.

    It has got to be an issue with the video card/retina display, but I've not noticed anyone else comment on this so far.

    Interesting!

    M.


  • f.lux team

    Hey @malclilley any chance you used Disable for the current app? If that's what happened, you can undo it: open the f.lux menu from the apps that are 6500k and uncheck Disable for current app.


  • f.lux team

    If it fades slowly you've definitely got "disable for current app" turned on. (Maybe we should have a global 'reset to defaults' for that.)

    If it flashes instantly, we'd like to know - most of these bugs are fixed as far as I know.



  • Hi @lorna. I have it set to Custom Colours - which gives me Disable 'for an hour', 'until sunrise' and 'for Safari'. None of these are checked. My macbook Air 11" works fine with F.lux, also my HP Folio (Windows 8.1).
    It must be something specific to the Macbook Pro Retina, I reckon.
    Perhaps El Capitan will sort it :)!
    Thanks,
    M.



  • Hi @herf ,
    F.lux works well on my other machines. I think this is probably something specific to Macbook Pro Retina.
    It's not much of a problem - I just have to go in and reset the Kelvin level to 4200 occasionally, in the evenings!
    Thanks,
    .M


  • f.lux team

    @malclilley Check that same f.lux menu from the other apps you use as well, chat, or your photoeditor or whatever. I have a Macbook Pro Retina too - a fast flash could be switching between GPUs, in which case gfx.io will help you debug.



  • @lorna getting off topic here, the main internal adjustable differences between my 11" Air and 15" Pro Retina are the screen calibrations. I notice that the Air has an LG screen which is happy at Apple's gamma setting of 2.2, where the Pro Retina oddly is much better with a gamma of 1.8. I'm not sure who makes the Retina screen for Apple - it could be Samsung - I really don't know. Out of interest, I arrived at the gamma settings using a Spider Calibration system, which I borrowed.
    I'll just keep messing around with it - the more you mess with stuff, the more you learn? :)!
    Thanks,
    M.


  • f.lux team

    Just to be sure you don't have any apps disabled, here is a way to reset f.lux to its default settings.

    1. Quit f.lux
    2. Run Terminal
    3. Type this at the prompt:
      defaults delete org.herf.Flux [enter]
    4. Run f.lux again

    If you are seeing 6500K in the Preferences, this is probably the best way to fix it.



  • @herf OK, thanks.

    I got the following response from Terminal:

    2015-07-27 17:45:05.650 defaults[5835:1661395]
    Domain (org.herf.Flux) not found.
    Defaults have not been changed.

    However, it has reset defaults and I had to confirm my geographic location.

    The program seems stable.

    I'll check it out at sunset and see what happens, but it looks happier.

    Thanks for your help,

    M.



  • @herf,

    Thanks for your help here - it's now working fine.

    M.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.