Screensavers



  • Hello, I’m using screensavers to boost my creative thinking and get a quick break. Flux, however, also seems to be taking a break: Each time I exit the screensaver (e.g. by hitting a key) at night, Flux is turned off. Only after a second or so does it dim the screen colours again. This ”flash of daylight” is hurting my eyes. Anything you can do to make Flux run all the time, even with Mac OS screensavers?



  • I have the exact same issue, one second of blue screen after the screen saver.
    Have been experiencing this for over a year (or 2 I guess), so it's started before El Capitan an Mavericks even.

    Setup:

    • Early 2011 MacBook Pro (MacBookPro8,1 / MC700LL)
    • OS X El Capitan 10.11.2
    • f.lux 36.6
    • Lightning to DVI cable
    • Dell U2412M external display

    Today I removed Flux entirely (via AppZapper) and reinstalled it again.
    I don't use 'Automatically adjust brightness' in OS X System Preferences.
    My Display Profile is set to 'DELL U2412M' but the problem also arises with 'Color LCD' default profile.
    I don't see a f.lux profile in Display Preferences.

    "Anything I can do to make Flux run all the time, even with Mac OS screensavers?"



  • I just wanted to "upvote" this with my comment. This problem also irks me. I'm on Yosemite on a 2012 12" MacBook, with f.lux 36.6, with just the built-in screen. The flash happens right after the MacBook wakes up from sleep, is taken out of screen saver by mouse or keyboard action right after the screen saver kicks in, or when I unlock the computer after it has been in screen saver mode for a while. The flash happens whether "Automatically adjust brightness" is on or off, and f.lux appears to be working otherwise.

    Basically it seems like it takes f.lux a second to "catch up" to the screen brightness being restored to full level after coming out of screensaver.



  • FYI, here's the workaround I came up with: turn off the screensaver and just allow the Mac to put the display to sleep instead. (In my case, I also switched a hot corner from "turn on screen saver" to "put display to sleep.") While I miss my screen saver, waking up the display from sleep fades in nicely to the proper color instead of flashing brightly.



  • @AndrewGHo Thanks for the smart tip! Though unfortunately I 'need' my branded screensaver for my company and clients..



  • After getting a new MacBook Pro, with a clean install (no Migration Assistant) and clean download of f.lux, I hoped and expected this issue would be gone, but it's still present...

    • Early 2015 MacBook Pro (MacBookPro12,1 / MF841LL)
    • OS X El Capitan 10.11.4
    • f.lux 36.6
    • Lightning to DVI cable
    • Dell U2412M external display

    Interesting to note: I also see the exact same behaviour when I navigate to System Preferences >  Displays > Color. Immediately when I click the 'Color' tab.
    I'm starting to believe it has something to do with the external display or color profile for that display.. Could it be?

    Would be nice to hear something from the f.lux about their thoughts.



  • When you get time @f-lux-team could you take a look at this if you haven't already?


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.