Flashing



  • Hello,

    I am on Yosemite on a Macbook pro and when evening comes, there will be a period of time when there are some flashes where the screen reverts to daytime level for about 1/2 second, and then goes back. This happens 3-4 times before it stops. I also have an external monitor hooked up, and it doesn't usually flash there, although it has done so once. Is there setting I can change?

    Best Regards,
    Josh



  • I've noticed this behavior recently, too. It just happened, in fact. It sometimes happens when flux isn't running, though I saw multiple flux "color profiles" installed in the Displays->Color system preferences.



  • This is on the "Support" page on f.lux's home page:
    https://justgetflux.com/faq.html?q=flash#



  • This doesn't occur when switching GPUs, but for me always exactly at 11:00 PM CET / UTC+2. For me it doesn't affect the MacBook's display, but only the external one.



  • @lorna what's the GPU locking program? I think it will fix the problem if you lock your computer to use one card (maybe the onboard graphics).

    Also, can you switch between the two? Does one not have the issue, if both of them have the issue, then I'm unable to help you. I don't have the level of expertise needed for this bug.

    Edit: maybe I'll soon get there though
    @thx01138 said:

    though I saw multiple flux "color profiles" installed in the Displays->Color system preferences.

    Could you post a screenshot, and let me know how many are listed? I'm not much of a mac user and haven't seen this problem (although when I had it in a VM I didn't see this). Maybe you could try deleting one of them and let me know if that fixes the problem.



  • I'm experiencing a 'flashing' on my 2015 13" macbook pro internal display as well. It only occurs when I connect/disconnect the power source though. Really odd.

    The 13" seems to only have a single GPU listed as "Intel Iris Graphics 6100".

    I'm running OS X 10.11 El Capitan Beta 3. This has been happening since at least the first beta, but I don't believe it happened in Yosemite.



  • The flashing in El Capitan is related to the backlight brightness being adjusted due to ambient light conditions. You can make it happen by adjusting brightness manually on the keyboard too.

    So any time your display is trying to make a subtle brightness adjustment, flux seems to cut out momentarily.



  • Yep. That's exactly it.

    That's beta software for you. I'm sure flux will come out with a fix sooner or later.

    Although the question is, I don't think flux has an auto-updater (at least if it does, it doesn't work for me).



  • @stalfos Yes. This is correct. I forgot to mention it. Super-obnoxious, but yeah, I know it's beta software. Just wanted to put it on someone's radar. Is there a repo to post issues/bugs?


  • f.lux team

    In El Capitan, if you go to System Preferences -> Displays you'll find a new setting called "Ambient Light Compensation". Turning this off fixes the problem.

    This new feature seems to be adjusting the response curve in bright rooms (based on Ambient Light Sensor readings). Since f.lux does most of its work at night when most rooms are dark, it might be possible for us to disable this feature at night, but leave it on during the day.

    I wonder if Apple will ship it on by default as they've done with the betas.



  • Thanks @herf I don't see this option though :(

    Am I missing something? I'm on a 2015 13" macbook pro with El Capitan.

    Here's a screenshot of my system description and display options:
    Evernote: OSX Screenshot

    Any additional help or pointers would be greatly appreciated. I did a bit of searching and didn't see why this setting would/wouldn't show up.

    Thanks again!



  • Here I have a MBP Retina 13" Early 2013, El Cap developer beta 3, no adaptative brightness option is shown. Those flashes are burning my eyes :'-(

    Interestingly enough, in daylight, when testing sunset or bedtime mode via flux preferences, manual brightness adjustment via dedicated keys does not trigger flashing, but moving to a room with closed curtains is a surefire way to trigger it.

    Reported this to Apple via feedback app.


  • f.lux team

    It should be under System Preferences > Displays. The behavior you're describing definitely sounds like that's what is happening. :( I see you have "automatically adjust brightness" checked in that screenshot, so try unchecking it.



  • I am experiencing the same issue with f.lux 'flashing' (disabling for half a second might be a better description) when manually adjusting the brightness at night. I'm running a MacBook Air with an external monitor and the 10.11 public beta. I'm using a relatively old 24" Cinema Display and can't see any options relating to ambient brightness in System Preferences -> Displays.



  • @lorna said:

    It should be under System Preferences > Displays. The behavior you're describing definitely sounds like that's what is happening. :( I see you have "automatically adjust brightness" checked in that screenshot, so try unchecking it.

    I don't have the setting either (and am experiencing the flashing). The auto-brightness setting doesn't fix the issue I'm afraid.


  • f.lux team

    The new Mac beta is working better when we write a color profile all the time. ("writeProfile")



  • @herf does that use more CPU power?



  • @herf I'm not sure how to enable this "writeProfile" in a color profile, but happy to follow any steps and report back what I get from testing.

    I can confirm that toggling the auto-brightness setting doesn't seem to have any affect on the flashing issue.

    When I try to 'calibrate' my internal display the Display Calibrator crashes unexpectedly and I get an error report - not sure if that's related, points to an issue with apple or would provide anything helpful here, but happy to report if so.

    Thanks again everyone.



  • I was happy to find this thread and disable the 'Automatically adjust brightness' setting but alas, the flashing continues. (As someone else mentioned, it's like Flux gets disabled for half a second. Repeatedly.)

    I'm on a mid-2012 MacBook Pro and using both the laptop screen and a Dell U2713HM .

    Is the Beta that the team members have mentioned available to the public?

    -Wendy


  • f.lux team

    @Breezio are you using more than one monitor? The Feature is named Ambient Light Compensation.



  • @wsmoak I haven't seen an available beta. I emailed and asked if the software had an open-source license and a public repo but got no response as of yet. Would love to help with debugging and trying to figure out how best to do that :)



  • @lorna Not all macs have the option to toggle ambient light compensation. My 2013 Retina MBP doesn't have it as an option in the displays preference pane when using the built-in or external displays.


  • f.lux team

    @seajay Can you describe exactly what's happening on your 2013 MBP? Is it new with El Cap? I'm thinking there are two different problems we're talking about.There are some problems with flashing when the GPUs switch, and that is a different (but similar) issue to the Ambient Brightness El Capitan problem. No publicly available beta yet but soon.



  • @lorna Yeah, absolutely. It's new with El Cap - been using flux for years on osx without issue before. The symptom presents itself when manually adjusting brightness using either the keyboard (f1/f2) controls or dragging the slider in System Preferences>Displays. Any manual change to brightness results in flux flashing off until the new brightness locks in, which is pretty jarring at night.


  • f.lux team

    This is super helpful, thanks. Hope we have a good answer for you soon. Meanwhile if you want, you could try gfx.io to lock one or the other card (I'm maybe making a big assumption that it's dual GPU here) and see if you can track down which one is causing the problem.

    @seajay said:

    @lorna Yeah, absolutely. It's new with El Cap - been using flux for years on osx without issue before. The symptom presents itself when manually adjusting brightness using either the keyboard (f1/f2) controls or dragging the slider in System Preferences>Displays. Any manual change to brightness results in flux flashing off until the new brightness locks in, which is pretty jarring at night.



  • @lorna Tried gfx.io and received the following error:

    • You are using a system that gfxCardStatus does not support. Please ensure that you are using a MacBook Pro with dual GPUs.

    That jives, since I'm fairly certain all 13" Macbooks use integrated graphics cards. The 2013 retina mpbs use Intel HD Graphics 4000.

    Of note, I tried disabling rootless and that fixed the problem.


  • f.lux team

    Oh boy, that is very interesting, thank you for the update. Wow.



  • @seajay Yeah, I know that's probably not the answer you were hoping for. I disabled rootless to see if it would help me get more functionality out of iStat Menus, which did work. It also fixed f.lux, which was an unexpected but much appreciated side effect.

    I know most users should definitely NOT be disabling rootless, since it's an important security measure. Still though, it's nice to have my old apps working properly again.


  • f.lux team

    Thanks for letting us know anyway, it's useful to know. I'm glad you got it fixed for now.



  • As of the latest El Capitan (beta 4) I can confirm that on a 2015 13" macbook pro the "Ambient light compensation" option appears and, when disabled, fixes the flashing issue.



  • I am on a 2013 13" RMBP on PB2 (aka Developer Beta 4) - there is no option to disable ambient light compensation

    Also yes, all 13" RMBPs do not have dual graphics cards - there is only Intel Integrated Graphics



  • @nchan2177 said:

    I am on a 2013 13" RMBP on PB2 (aka Developer Beta 4) - there is no option to disable ambient light compensation

    Also yes, all 13" RMBPs do not have dual graphics cards - there is only Intel Integrated Graphics

    Yeah, still same deal on beta 4 with my 2013 13" rMBP. No ambient light option. Still have to disable rootless to get flux to work.



  • I am getting similar problem on Mac Mini 2010 with 2 identical Dell monitors attached through the HDMI and MiniDisplay Ports. Both monitors use identical profile setting ( each of the monitors has its own ICC profile).

    The issue with flickering is when I wake up the machine from Stand-by. When the monitors turn on, they start flashing quickly about 3 times between the optimized (flux night mode) colour and totally white (I guess 5000) . When Flux profile is not active during daytime, there is no flashing or maybe it's very negligible.

    I checked the event log and there is an entry that seems it's when the flashing happens...

    2015-08-14 1:42:47.991 AM Flux[589]: Display list confused, doing full reset.



  • I just upgraded to el capitan and I am facing the same issue. I am on a RMBP early 2013. When I choose the color effects -> Movie Mode i f.lux I am getting the flashing behaviour. It renders f.lux impossible to use .



  • the flashing stops temporarily if the f.lux menu has been opened via the menu bar and stays that way as long as the menu is open even with movie mode enabled.



  • @HG I have the same problem here. Old 2008 MBP actually, but still a workhorse minus battery life.

    Here's an WEBM and GIF link I recorded crudely with my phone:

    http://gfycat.com/HatefulAdvancedHypsilophodon
    http://giant.gfycat.com/HatefulAdvancedHypsilophodon.gif (note: 11mb GIF, 28x smaller is link above)

    Specs: 15.4" 1400x900 Built-in Display (no Retina), dedicated NVIDIA GeForce 9400M 256mb graphics card
    2.8 GHz Intel Core 2 Duo
    8G GB 1067 MHz DDR3 memory (back when you could swap out the RAM, ha! upgrades!)

    One built in display, one 24" Asus external monitor.

    Screenshot galleries of my Laptop "About this Mac" and displays versions link below. There are no "Ambient" light settings available in my Display preferences menu options as far I can tell; either my laptop is too old to support that bit of hardware or something but I get the same flickering problem described in "Movie Mode" on El Capitan 10.11.0. F.lux version 36.3.

    http://imgur.com/a/cG8bc



  • @lorna @herf is there a possible workaround or fix on the way for this flashing issue ?


  • f.lux team

    This looks like the Ambient Light Compensation issue, but we thought Apple had pulled it from El Capitan, so we took out our workaround.

    The last build with this fix was 36.0 - so try this one and see if it helps? It has a lot of bugs we fixed (but they are reasonably minor).

    https://justgetflux.com/mac/Flux36.0.zip



  • @herf, I confirm that in my case, Flux36.0.zip does not have the flashing problem



  • @herf I am on version 36.3. The Ambient Light Compensation option does not show up in display prefrences. I am guessing that it did not make the final cut for el capitan and Apple yanked it .



  • @herf I just installed v36 from your link and it seems to fix the issue with flashing. Thanks.


  • f.lux team

    Can either of you post the Apple Menu->About This Mac "version" number?

    So if you are on the GM there must be some cases where the behavior is there but not something you can turn off.



  • Here are my specs
    RMBP - early 2013
    OS X El Capitan
    V10.11



  • I just found this thread after experiencing the flashing issue in both movie mode and darkroom mode on El Capitan on my Early 2011 13" MBP in 36.3. I can confirm the 36.0 version that herf posted does not have this issue, so I've downgraded to it.

    Thanks for a great product guys!

    Posted from a darkroom-mode set MBP at 11pm on my second day of daylight savings (so darkroom-mode very much needed).



  • @herf
    OS X 10.11 (15A284), and I never used the preview builds.
    This is on an MBP with a NVIDIA GeForce 8600M GT 256 MB GPU, doesn't have integrated GPU, just discreet.

    Just to resume:
    With v. 36.3 I get the flashing problem if I turn on any of the 'Color Effects' at any time of the day.
    With v. 36.0 the problem is gone.



  • Version 36.0 downgrade movie mode flashing problem almost goes away.... I still get one flash (tolerable!) before it settles into movie mode color level completely. Thanks for the tip. Hope there's enough information here to help you resolve and track down the issue!


  • f.lux team

    Merged all the fixes into a new build - please try:

    https://justgetflux.com/mac/Flux36.4.zip



  • @herf
    Working well here so far, thanks!


  • f.lux team

    For those still having trouble: a reboot AND 36.4 seems to be the magic combination.



  • The issue with flickering when wake up the machine from Stand-by - issue still persists in even in the latest update.

    When the flashing happens there is a log:

    2015-08-14 1:42:47.991 AM Flux[589]: Display list confused, doing full reset.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.