Flux suddenly starts disabling for Firefox when unchecked?

  • Hi,
    I am running windows 10 20H1, and suddenly Flux is disabling for Firefox even when the option to do so in the "disable" menu in Flux is unchecked. I have tried "checking" and "unchecking" the option again in Flux hoping it would get it to work properly again, but it made no difference.

    I get a windows notification that "Flux is disabled for Firefox" as soon as I start Firefox.

    I only want to disable Flux when I am running apps in full screen mode (Firefox is not set to run in full-screen -- it has the menu bar showing).

    Can you please tell me how to re-enable Flux to run with Firefox?

  • I restarted my computer, but that didn't help.

    I then decided to try unclicking the "disable for fullscreen apps", and it started working again.

    So, I thought that maybe Firefox is somehow telling windows 10 that it is in fullscreen mode when it really isn't. However, that doesn't explain why I got the specific notification "Flux is disabled for Firefox", so I think that there's some strange sort of bug going on here....

    At least there is a workaround -- but I would like to have the Flux work properly and again set it to disable itself automatically only when I am watching full screen videos. This worked just fine for me until today.

    In case this helps, here's my software/hardware environment:
    Windows 10 x64 20H1 with all updates applied (other than 20H2), Firefox 94.0.1.(64-bit), Flux 4.120.
    HP Z440 workstation running a Xeon E5-2630 V3 processor with 32GB of RAM,
    NVIDIA GeForce GTX 1060 3GB graphics card,
    my display is a TCL 65R635 4K TV. I am running it in 4k resolution with HDR enabled in Windows 10.

  • Here's the Flux "Driver info":
    NVIDIA NVIDIA GeForce GTX 1060 3GB (20210913)

    Generic PnP Monitor, 800 x 450mm, built 2017
    R=0.642578 0.332031
    G=0.322266 0.623047
    B=0.146484 0.055664
    W=0.280273 0.290039
    sRGB gamut: 95%, AdobeRGB gamut: 66%

    Unlimited gamma ramp=1, Internal ramp=0
    Monitor 1 on NVIDIA GeForce GTX 1060 3GB
    Has VCGT profile=0, Gamma Ramp works=1

    Windows Build: 19042.1288

    It is interesting that it shows the display size improperly -- it says 800mm x 450mm, when it should be 1435mm x 800mm. Also, this TV was built in 2020, not 2017, but it may be getting the year from the Denon home theater receiver that it is connected through?

Log in to reply