f.lux disables ICC profiles



  • I am using f.lux for Windows version 4.120, and I noticed it disables ICC profiles in Windows. I set up the ICC profile, it works but then as soon as I go back to the desktop it gets disabled. The problem goes away when I quit or uninstall f.lux. There aren't any settings in flux that fixes the problem. Only removing it fixes it.



  • f.lux loads the system ICC profile when it starts up. (There was a super-awful leak in Windows that kept us from reading them more than once. On the Mac we do this properly.)

    So if that's is the issue - whenever you change the system ICC/ICM profile you should restart f.lux after that.

    If that's not the issue, please post f.lux options > driver info or email us the ICC file and we'll take a look. There have been ones in the past that our parser doesn't handle, so in that case, something like this could be happening also.



  • I've tried restarting f.lux and reinstalling f.lux with the profile active. No change. Here is the driver info:

    NVIDIA 26.21.14.3200: NVIDIA GeForce GTX 960 (20190724)

    Generic PnP Monitor, 885 x 498mm, built 2008
    Chromaticities:
    R=0.639648 0.330078
    G=0.299805 0.599609
    B=0.150391 0.059570
    W=0.312500 0.329102
    sRGB gamut: 100%, AdobeRGB gamut: 64%

    Generic PnP Monitor, 544 x 303mm, built 2021
    Chromaticities:
    R=0.649414 0.340820
    G=0.310547 0.630859
    B=0.147461 0.050781
    W=0.313477 0.329102
    sRGB gamut: 92%, AdobeRGB gamut: 65%

    Generic PnP Monitor, 527 x 296mm, built 2014
    Chromaticities:
    R=0.653320 0.334961
    G=0.323242 0.611328
    B=0.153320 0.061523
    W=0.313477 0.329102
    sRGB gamut: 93%, AdobeRGB gamut: 65%

    Generic PnP Monitor, 527 x 296mm, built 2016
    Chromaticities:
    R=0.653320 0.334961
    G=0.323242 0.611328
    B=0.153320 0.061523
    W=0.313477 0.329102
    sRGB gamut: 93%, AdobeRGB gamut: 65%

    Unlimited gamma ramp=1, Internal ramp=1
    Monitor 1 on NVIDIA GeForce GTX 960
    Has VCGT profile=0, Gamma Ramp works=1
    Monitor 2 on NVIDIA GeForce GTX 960
    Has VCGT profile=0, Gamma Ramp works=1
    Monitor 3 on NVIDIA GeForce GTX 960
    Has VCGT profile=0, Gamma Ramp works=1
    Monitor 4 on NVIDIA GeForce GTX 960
    Has VCGT profile=0, Gamma Ramp works=1

    Windows Build: 19043.1288



  • This says we failed to find any VCGT header in the profile (which is the part that tells us what to do).

    There are some notes about other kinds of profiles here:
    https://justgetflux.com/faq.html?q=vcgt

    If you think your profile should work with f.lux - like if you used a hardware calibrator to make it - you can email the file to us (support at justgetflux.com)



  • @herf
    I checked out the link you provided. There is no profile for my monitor in the TFT Database. My monitor is the BenQ EX2510. So I was able to get f.lux to work with QuickGamma. So far flux and the QuickGamma settings are working together. Even after a restart. The only (new) problem I have now is with Windows Photo Viewer, but that is unrelated. And also unmaintained software in Windows 10. Time to ditch it, unfortunately.

    Thank you for your help!


Log in to reply