f.lux doesn't work properly with dual monitors when both are calibrated and using different ICC profiles



  • Windows 10 Pro 21H1

    On my system, I have two Asus PB278Qs connected via DisplayPort to an Nvidia GTX 1070.

    I have them both color calibrated (using a colorimeter) separately, and both have different ICC profiles.

    Now that they both have their own profiles instead of sharing the same generic PB278Q profile, f.lux only appears to apply to a single screen (the primary).



  • Can you post f.lux options > driver info so we can see the details?

    This sounds similar to a configuration we have here (which is working as it tends to always work here!)



  • ---------------------------
    Driver info
    ---------------------------
    The information below is already on the clipboard. Paste to the f.lux forum or email us for help.
    
    NVIDIA 30.0.14.7212: NVIDIA GeForce GTX 1070 (20210913)
    NVIDIA 30.0.14.7212: NVIDIA GeForce GTX 970 (20210913)
    
    ASUS PB278, 597 x 336mm, built 2014
    Chromaticities: 
      R=0.666016 0.330078
      G=0.309570 0.629883
      B=0.150391 0.040039
      W=0.313477 0.329102
      sRGB gamut: 99%, AdobeRGB gamut: 69%
    
    ASUS PB278, 597 x 336mm, built 2014
    Chromaticities: 
      R=0.666016 0.330078
      G=0.309570 0.629883
      B=0.150391 0.040039
      W=0.313477 0.329102
      sRGB gamut: 99%, AdobeRGB gamut: 69%
    
    Unlimited gamma ramp=1, Internal ramp=1
    Monitor 1 on NVIDIA GeForce GTX 1070
      Has VCGT profile=1, Gamma Ramp works=1
    Monitor 2 on NVIDIA GeForce GTX 1070
      Has VCGT profile=1, Gamma Ramp works=1
    
    Windows Build: 19043.1288
    
    ---------------------------
    OK   
    ---------------------------
    

    Color-wise, they both calibrated substantially differently, and are using two different ICC profiles.



  • Okay we do know that NVIDIA has some settings in its own control panel that override color settings - can you check for "reference color" mode or something like that in the NVIDIA Control Panel? It should be turned off for f.lux to work.


Log in to reply