F.lux does not work when screen wakes up



  • Below is my PC configuration:
    Windows 10 v2004 OS Build: 19041.928
    Intel i7-9700K 3.6GHz
    32GB RAM
    EVGA GEForce RTX 2080
    Three monitors - ViewSonic VP2785-4K + VP2785-4K + VP2768-4K
    f.lux v4.118

    Issue:
    In the power and sleep settings of Windows 10, i have setup the following:
    Screens turn off after: 15 mins
    Sleep: Never

    The monitors turn off after 15 mins if not being used, as expected. In the night, when i wake the monitors using mouse or keyboard, f.lux doesn't work and the brightness is on full blast mode. I try to reset the display driver using the Ctrl+Win+Shift+B option, it resets f.lux correctly, sometimes it doesnt and sometimes only some of the monitors. If i exit f.lux and restart, it works fine.

    This issue is consistent and repeatable.

    If i don't turn off screen and use screensaver instead, there are no issues. I only see issue when i set the screen to turn off after some time. This is not a sleep mode issue as i don't set my PC to go to sleep.

    Is there something in the monitor settings i need to change?
    Is there a setting in windows i need to change?

    What information would you need to debug this issue further?

    Thanks in advance!



  • I have the same problem.
    I found that if I toggle the windows notification sidebar open and close it again, or minimize a browser window and maximize again, flux starts working.

    I have flux set to disable on fullscreen apps, and I think it's reading the screen turn off as a full screen app for some reason. Going to test by turning off disable for full screen apps and see if the issue still occurs.


Log in to reply