Two monitors - sometimes, after the power saving mode, the monitor turns on to full blast non-flux



  • I have two monitors. One is on DVI mode - one is on DisplayPort mode. My monitors go to sleep after 1 minute of idle time. But when I use the mouse to wake it back up, the DVI mode doesn't always go back into Flux mode, instead hitting full blast blue light and all those melatonin-shattering shenanigans.

    Any ideas how to resolve this? I try to avoid looking at that monitor (it's my secondary monitor, so it's not as hard), but sometimes I have to...



  • Bumping this up for assistance - also, alt+end does not seem to work unless I physically open the app to get this monitor thing resolved.



  • No one? Really is basically rendering f.lux useless since I have to disable it in order to enable it and that invalidates its effectiveness.



  • Hi @tamar - can you post f.lux options > driver info?
    Usually these problems can be helped with an upgrade to video drivers.



  • @herf thank you for the reply. My monitor drivers are current, and according to Windows, these are the correct drivers for the video cards as well.

    Intel Corporation 27.20.100.8682: Intel(R) UHD Graphics 630 (20200905)
    NVIDIA 27.21.14.5671: NVIDIA GeForce GT 710 (20200930)

    Dell U2713H(Digital), 597 x 336mm, built 2014
    Chromaticities:
    R=0.679688 0.309570
    G=0.209961 0.700195
    B=0.147461 0.053711
    W=0.313477 0.329102
    sRGB gamut: 102%, AdobeRGB gamut: 99%

    Dell U2713H(DP), 597 x 336mm, built 2014
    Chromaticities:
    R=0.679688 0.309570
    G=0.209961 0.700195
    B=0.147461 0.053711
    W=0.313477 0.329102
    sRGB gamut: 102%, AdobeRGB gamut: 99%

    Winlimit=0, 1
    Monitor 1 on Intel(R) UHD Graphics 630: VCGT=0 gamma=1
    Monitor 2 on NVIDIA GeForce GT 710: VCGT=0 gamma=1

    Windows Build: 19041.928



  • If the issue is with the NVIDIA-connected display...

    Can you look around the NVIDIA Control Panel and see if color settings are changed there? We are noticing some issues with new NVIDIA drivers, in that they seem to override the Windows colors in some cases.

    I would recommend an update to (even newer) 2021 drivers as well.



  • Hmm, it says "other applications control color settings" so I'm not sure they're overwritten.

    I don't see 2021 drivers for NVIDIA, just drivers from December 2020 that I updated - which removed the "other applications control color settings" feature in the NVIDIA app. I'm pretty sure it lets other apps control it though...might help to have some help page on this, however.



  • Any additional thoughts, @herf? Not really sure how to override those NVIDIA settings...



  • I figure like the only reasonable workaround for this is a Disable > for a second... but maybe I'm wrong. Driving me nuts though.



  • Is there a checkbox called "reference mode"? It should be disabled.

    I am not yet sure what they are doing with this driver, it seems to override the windows settings in some cases. There may be the option to rollback to something earlier in 2020 also.



  • There is an "override to reference mode" that is unchecked under the Adjust Desktop Color Settings. Is that "disabled" or is it "enabled?" Because it's still not working at this current default.



  • Okay we are puzzling over this NVIDIA update here (it seems remarkably to do its own thing most of the time with color settings). f.lux is being treated better than most apps, actually.

    Some ideas:

    1. Do you have any way to plug both monitors to the same card (rather than split across Intel & NVIDIA), or does your port setup require two?
    2. Can you look around again in NVIDIA Control Panel > Display > Change Resolution and see if there is a menu like "Apply the following settings" says? Mine says "NVIDIA" vs. "default"
    3. If all this fails, perhaps try rolling back to an older (early 2020) NVIDIA driver instead? https://www.nvidia.com/Download/index.aspx?lang=en-us


  • So my issue is that my integrated graphics card is working and doesn't exhibit this behavior- I'd be nervous to switch to that because then I might get two monitors on full blast non-flux.

    Step 2: the menu doesn't say much. Screenshot here: https://imgur.com/a/eEY3DVv

    Anything else you think I should try or should I just roll back the drivers?


Log in to reply