(Windows 7) F.lux suddenly stopped working despite no changes to computer?



  • Hello,

    So earlier today, I quit out of a game I was playing (fullscreen so f.lux was disabled) and f.lux didn't turn back on after that.
    I did try to restart and run the 24h preview (it did the same before, and doing that fixed it) but nothing made it work again.
    I tried restarting my PC/reinstalling f.lux etc., the usual fixes, but nothing worked, I didn't update my drivers or anything recently.
    I did try to install a similar program to see if it was f.lux specific (Sunset screen) but that too wasn't working so I think it's related to my hardware somehow? Like I said, I did not update my drivers before f.lux stopped working (they should be up to date anyway) so I'm not sure what gives?

    As this was asked in a previous thread, my GPU is running 8-bit. I'd appreciate any help, my monitor does have a yellow light filter built in, but it's kind of a pain and green-ish for some reason but it'll do for now.

    Advanced Micro Devices, Inc. 27.20.14501.18003: Radeon RX 5500 XT (20201113)

    Moniteur Plug-and-Play generique, 531 x 299mm, built 2018
    Chromaticities:
    R=0.644531 0.332031
    G=0.315430 0.619141
    B=0.151367 0.065430
    W=0.313477 0.329102
    sRGB gamut: 97%, AdobeRGB gamut: 67%

    Winlimit=0, 0
    Monitor 1 on Radeon RX 5500 XT: VCGT=0 gamma=1

    Windows Build: 7601



  • It looks like the Radeon driver updated rather recently (Nov 2020 date there) - so you may need to try a driver rollback until it's working better...



  • @herf Alright, thanks, but I do remember it working using that same driver so that's pretty weird.
    Are there any plans to get it working on newer drivers? I miss my screen tint...


Log in to reply