Flux does not start up correctly on Win10 dual monitors



  • My setup:
    ~Flux version: 4.118
    ~OS: Win10 Pro build 19042.330 (Windows Insider, beta channel)
    ~GPU: GTX970 (driver 451.52)
    ~2 Monitors: (1) ASUS VX238H Black 23" 1ms (GTG) HDMI Widescreen LED Backlight LCD Monitor (primary monitor)
    (2) Asus VS247H-P 23.6-Inch Full-HD LED-Lit LCD Monitor
    ~Flux settings: Wider slider range ENABLED
    Use GPU for better quality with very warm colors ENABLED
    Use Display data for bettter color accuracy NOT ENABLED
    Always use Windows internal color table NOT ENABLED
    ~Other: Win10 Night Light is turned OFF

    FIXED:

    So I've used Flux for a long time. A few months ago, I noticed that Flux is not working properly on Win10 startup. At the time, it was giving me discolored dots (they were greenish/dark turquoise) on startup on my primary monitor (1). That piece of my problem was apparently was fixed in a recent update but other symptoms of my problem still exist.

    STILL A PROBLEM:

    In addition, it was having an issue where the color settings were not being correctly applied. I use flux in "reduced eyestrain" mode and on startup. The color should be more orangish but this is not being correctly applied at startup so my monitor colors would be either normal or very close to it (I couldn't tell). Additionally, the Page Up/Page Down hotkeys to change my brightness settings do not work while Flux is in this bugged state.

    However, I found that I can get Flux to function correctly with a weird sort of reset. I originally was doing this by unplugging/replugging one of the monitors (effective sometimes but not always) but I found that I could get the desired effect by doing Windows Key + P, changing my display to single-monitor mode (either the primary or secondary works) and then doing Windows Key + P again to go back to dual monitors. For whatever reason, that fixes the colors and allows me to adjust the brightness via hotkey again. Flux works 100% normally from then on...until I either sleep or shutdown/reboot. Then I have to redo this process to get it to work correctly again.

    I keep my GPU drivers up to date and this problem has existed through the past few NVidia drivers.


Log in to reply