Not working at nighttime, f.lux 4.115 Win10 v2004



  • Win10 release 2004 seems to have broken f.lux when Windows thinks it's nighttime.

    Windows Night Light feature is turned off and strength is about 50.
    Monitor is an Asus ProArt, via HDMI to an NVIDIA GT635 graphics card.
    Brightness set on the Asus itself is set to 50%

    During the day, Alt PgUp, PgDn work as intended, they brighten and dim the display while keeping the colour tint neutral.

    At nightime f.lux doesn't work. Alt PgUp, PgDn do cause the f.lux widget to appear briefly and it's scroll bar changes, but the display itself does not, it remains medium-bright and not tinted.

    If I go into Display Settings via right-click on the desktop (this was tried at night), the monitor goes very bright; I don't remember if I changed the Night Light strength or not but after I closed that, then f.lux could dim the display but not as much as earlier this year, and not with as much red tint as it should.

    Is there any other info or tests that would be useful to get more info on the new problem?
    Or would there be some settings in V4.115 that by default (because I just used it and didn't personalize anything) happen to be in a mode causing it to not have any strong effect at night, or less than earlier this year.

    Thanks!



  • Updated to V4.118, still the same problem.
    At nighttime Alt PgUp/PgDn dims or brightens. It's 11:05 PM now and the range is 2% to 60%. But it doesn't dim as much as earlier this year, and does not become red tinted when dimmed, just remains neutral.

    Changed the pulldown to "recommended colors". It was on "custom colors" before, for some reason. Alt PgUp, PgDn now change between 0 and 14% but the brightness of the display does not actually change.

    In Features and Notifications, backwards alarm clock is selected, use display data for color accuracy, use GPU for better quality. Use Windows internal color table is not selected.

    Driver info is:
    NVIDIA 26.21.14.4112: NVIDIA GeForce GT 635 (20191024)

    Generic PnP Monitor, 597 x 336mm, built 2013
    Chromaticities:
    R=0.679688 0.309570
    G=0.209961 0.700195
    B=0.147461 0.053711
    W=0.313477 0.329102
    sRGB gamut: 102%, AdobeRGB gamut: 99%

    Generic PnP Monitor, 521 x 293mm, built 2017
    Chromaticities:
    R=0.650391 0.333008
    G=0.316406 0.612305
    B=0.152344 0.067383
    W=0.313477 0.329102
    sRGB gamut: 96%, AdobeRGB gamut: 66%

    Winlimit=0, 0
    Monitor 1 on NVIDIA GeForce GT 635: VCGT=0 gamma=1
    Monitor 2 on NVIDIA GeForce GT 635: VCGT=1 gamma=1

    Windows Build: 19041.329

    Um, the cancel button on the f.lux Options panel is greyed out and the Done button doesn't dismiss it! :)

    Same visual response on the HDMI and VGA monitors, one is not different than the other.

    Windows night light is off. No difference whether the strength is 0, 50, or 100, f.lux is still prevented from working.

    Turn night light on, f.lux still has no effect whether the strength is 0, 50, or 100.


Log in to reply