Neon colours with f.lux



  • Dear all, I have a weird problem with f.lux where certain colours (especially blue) become painfully bright when f.lux is active while the other colours are correctly muted/tinted - please see attached screenshot (taken with my mobile phone - a Snipping Tool screenshot shows normal colours). It's actually not as apparent in the photograph, but the blue is intense enough to be painful to look at. I've only had this problem with one laptop - a Dell Latitude 7490 - while my other laptops are alright. Does anyone have any idea what could be the cause?

    Intel Corporation 24.20.100.6286: Intel(R) UHD Graphics 620 (20180815)

    Generic PnP Monitor, 309 x 173mm, built 2016
    Chromaticities:
    R=0.639648 0.330078
    G=0.299805 0.599609
    B=0.150391 0.059570
    W=0.313477 0.329102
    sRGB gamut: 100%, AdobeRGB gamut: 64%

    Monitor 1 on Intel(R) UHD Graphics 620: VCGT=0 gamma=1

    Windows Build: 17134.1365

    neon blueb.jpg



  • It's normal. I don't know the technical explanation, but all I know is that it's normal. To human eyes, blue is the most intense color. To get around this, make the color temperature even warmer.



  • Hi TwoCables,

    Thank you for your fast reply! Unfortunately this is not the "normal" effect with blue (or green) that you're referring to. As comparison, I've uploaded a photo of my other laptop which has no problem - notice that the blue screen (for want of a better term) of the "This PC" icon and also the blue arrows in the Recycle Bin icon are suitably dimmed with the rest of the screen. This is the case for my other computers using f.lux. I've uploaded the problem laptop's screenshot as a comparison - it's immediately apparent which one is which.

    In the case of this problem, the blue channel appears to be not dimmed at all, or even intensified when f.lux activates. Also, it's not just blue that's affected - the green channel as well so, for example, the Skype green tick (showing status as "Available") also suffers from this non-dimming/intensification.

    IMG_20200511_141212b.jpg IMG_20200511_141248b.jpg



  • Are you sure the settings are the same? That is, are you using the same color temperature in both photos?

    The reason I ask is that, what I see is exactly what I was telling you: when you set the color temperature warm enough, that “problem“ that you are describing goes away. It doesn’t suddenly go away at some point, no, but it becomes less and less of a visual problem the warmer and warmer your color temperature setting becomes. I’m using my phone right now to post this, but when I turn my computer on later I will find the color temperature area or range where I notice the blues begin to become invisible such as in your second photo.

    Your first photo looks to me like your color temperature is in the upper 2000s or lower 3000s. Your second photo looks to me like the color temperature is at around 1200 or possibly 1900.

    If that’s not the case, then the other issue is the difference between display technologies. What is the display technology of the monitor in the first photo? The only display technology that I have experienced with f.lux so far is LCD TN panel technology.



  • Also, the same thing happens with Night Shift in iOS, iPadOS, and macOS. It also happens to Night Light in Windows. It’s just what happens when the color temperature is warm but not so warm that it’s mostly red, such as when you set the color temperature to 1900 or warmer, like 1200.

    It doesn’t mean that the blue light isn’t being reduced or filtered out.



  • Eureka! I think I found the solution. And it might work for people with similar setups. TL;DR: if you're using Intel (U)HD Graphics, play with the Color Settings in the Intel (U)HD Graphics options.

    First off, thank you TwoCables for taking the time and trouble to engage and try to troubleshoot this with me - I appreciate it very much. To answer your question though, the trouble laptop uses an IPS LCD while the good laptop uses a PLS LCD - which is just Samsung's take on IPS so for all intents and purposes is identical to IPS.

    The problem really isn't what you had described, but on reading your comment about the possible difference in colour temperature I decided to play around with the sliders in both computers to make sure they were set the same. (BTW, I notice that the uploaded photos don't show the blue as intense as the originals because I had to resize them - since the originals and resized photos are jpg I suspect that the processing might have changed the colour information.)

    And this is when I discovered a crucial clue: I was sliding the temperature slider on the trouble laptop from one end to the other, and in doing so I found that as the temperature became warmer and warmer, everything became redder - except blue. Blue stayed at full intensity, and was not being reduced or filtered out (which is why I say the problem isn't what you thought it was). Of course, with everything else darkened, the unfiltered blue stood out like a sore thumb and became extra painful on the eyes.

    Then I tried with my other laptop, which works fine with f.lux and Windows Night Light. As expected, all colours were reduced together, so that everything looked like it should - regardless of where the temperature slider was. I've uploaded a photo of both laptops with the temperature sliders at the warmest (left extreme) - you can see that the red tint is similar but for the trouble laptop the blue stays bright.

    IMG_20200512_191029b.jpg

    So I then wondered what could be the cause. On a hunch, I decided to open up the Intel HD Graphics control panel and look for some sort of colour/contrast enhancement settings. I found a "Color Settings" section but no enable/disable switch for all enhancements. Instead, there was a slider for "Color Gamut". The default is midway between "Natural Colors" and "Vivid". I slid the slider to "Natural" and lo and behold! the blue channel started dimming as well! I've uploaded 2 photos, showing the difference between the default setting (with the blue undimmed) and slider set to Natural (all colours dimmed properly)

    IMG_20200512_191131b.jpg IMG_20200512_191141b.jpg

    As a finisher, I've uploaded a photo of the 2 laptops again, but this time with the trouble laptop's colour slide set to "Natural'. The trouble laptop's screen is now free of the glaring blue channel. Voila!

    IMG_20200512_191024b.jpg

    So, many thanks to TwoCables for that comment that kickstarted the thought process. I'd been barking up the wrong tree for months!



  • I am speechless. That, wow, I don’t know, you would think that since Windows 10 has Night Light, Intel should have made sure this didn’t end up being a problem somehow. Nice work figuring it out!


Log in to reply