Graphic issues (workaround)



  • Hi everyone.

    About one month ago some strange issues became visible on my pc.

    Especially when the pc was idleing (all energy-saving options are disabled) the graphics driver
    become unstable. The most obvious misbehavior was:

    • Videos playing on f.e. youtube stop (audio keeps playing) when there is no mouse activity
      -> Video repeats to play while your moving the cursor and immediately stops if you stop moving the mouse too.

    • Spotify Webplayer stops playing the music when there is no mouse activity (rest like with youtube videos)

    • Submenu's like in the systray or taskbar are 50% transparent when you activate them by right-clicking and wont disappear.

    • Graphs like those visible in the taskmanager wont refresh anymore until you switch the tabs

    • After a few of the above mentioned actions the computer gets slower at first and a few seconds after starts hanging until you have to do a hard-reset.

    I looked through many applications on my pc, tried to figure out what triggers that strange behavoir. I even did a clean reinstall of the graphicsdriver and a few other things.
    One day i saw only accidentially that the displays flickert about 2 seconds and flux gained control while switching to the configured night-color-mode. I was able to get the same behavior as bevor when trying to open a context menu in systray or similar actions.

    So i went closing flux via context menu in systray. But i noticed that flux didnt terminated itself so i went on killing it via task manager. The behavior was still present. I decided to kill the graphics driver host process too. That resulted in 2 displays getting a black screen and coming back 2 seconds after. Then everything was fine. No further issues until i restarted the pc or reopend flux.

    I was not able to determine the actual issue that is causing this problem but it has to be something about how flux and the grapics-driver are present at the same time.

    My specs:

    • Win 10 1909 ( Pro )
    • flux 4.111
    • AMD Ryzen 5 1600x
    • 32 GB RAM DDR4
    • RX 580 8GB ( Radeon Software v20.4.1 )
    • 2 Monitor Setup both HDMI with 1920x1080 @60Hz

    I hope my post might help someone to get an workaround.

    Regard


Log in to reply