f.lux disabled automatically for remote desktops



  • Since recent outbreak of Coronavirus, I've been working from home, full hours, over VPN and RemoteDesktop. I've noticed that there's something off on my home display, the colours were not set as in the office. So, I installed f.lux, set it up, and I was satisfied, for the time being. Then I noticed that f.lux disables the colour scheme whenever I run RD in full-screen mode. There seems to be no option to set the colours right.

    I've tried switching-off f.lux on my office PC, or on my home PC, I've tried running it on both PCs, but nothing seems to work. As soon as I go to full-screen with RD on my home PC, the light turns too intensive. So I did a test.! If I manually stretch my RD window to imitate full-screen, f.lux works as usual. When something's wrong, blame Microsoft, right? Then I said RD is trash anyway, I installed Team Viewer. I was unpleasantly surprised when I got the same result. Everything's fine until I click that full-screen button. Alright then, third time's a charm! I've even installed another remote app, this time VNC. I've connected it, but I got the same unfavourable result, again. Third time was not a charm.
    All of the apps behave in the same manner: The moment I go full-screen, my colour scheme is no more. I get the same eye-straining colours that f.lux is (was) helping me reduce. IMO it's not the remote access sw, it's f.lux, there's a fixed setting which disables it on RD when apps run in full-screen. That's a useful feature, especially for games, but it's disadvantageous if one is doing programming and/or database.

    Please, look into this. In this times of trouble, a great number of people is working from home full hours, and really helpful tool as f.lux is not functioning as one would expect. I'm a SW developer myself, but I say this as long-time regular user of f.lux: This feature (disable f.lux in full screen) should NOT be automatic, it should be customizable.
    Thank you for a great product and your time.


Log in to reply