Frequently have to turn off/on the "white" cursor fix.



  • My cursor is constantly switching back to the full brightness mode, forcing me to open the options and flick the option off and on to reset it.

    This generally happens with fullscreen games, but has happened other times with an unknown cause.

    The issue's been around for ages, and persists through reinstalls (both program and Windows)

    Is there a fix? Thanks!



  • We are using the system setting to turn off the hardware cursor, because some video drivers do not apply the color profile to the cursor. When we do this, the system renders the cursor using the desktop compositor (that draws everything else), so it can be slightly slower.

    Any game could turn this on or off - if this is common (can you say which games?) we could try to flip it back when you go out of a fullscreen game. But I wouldn't want to be too aggressive about it, because then we might mess up cursors in the game.



  • Is it possible that this could be a separate option/checkbox? This would be something I would be happy to beta test or something. I have this problem constantly and it can be really frustrating to have to make a minimum of 10 clicks (I counted) to cycle through turning the "Software mouse cursor" Off, then click done, then reopen and turn the "Software mouse cursor" back On.

    Other suggestions to possibly help reduce the frustration is adding an "Apply" button that doesn't close the f.lux Options window, or a "cycle software mouse cursor" button or effect. Any of these would at least make it easier to manually fix the off/on process rather than having to program an auto-fix.

    If you'd like a list of games that require this, I'd be happy to start keeping track and let you know, but it's probably 40% of the games I play.


Log in to reply