f.lux does not work on second monitor



  • Hello,

    So, I'm using my laptop with two external monitors (laptop monitor disabled), the first one running over HDMI and the second one over an USB 3.0 to HDMI adapter (running Fresco Logic). The monitor over HDMI works perfectly with f.lux while the other, although it shows in diver info and in the disable menu, does not. Before I left for a couple of months in the summer, both monitors worked just fine. Now, when I returned in October and plugged the monitors back in, I noticed that the second one was not working with f.lux. I'm running Windows 10 Pro, version 1903, OS build 18362.418. I also attached below a picture with diver info. Thanks in advance !

    0_1571941963797_f_lux_driver_info.png



  • Thanks for the report - right now we do not have a Fresco Logic adapter in house, and there are several bugs with multiple monitors in Windows 10. Was f.lux working with this adapter previously?



  • @herf Thank you for the response. Yes, f.lux was working perfectly with the adapter before (before being in the summer, so I think before the latest windows big update which was the May update that rolled out later in the year because of the bugs).



  • HI buddy, this happens mostly due to not using the connections so something gets freeze. Do try cleaning and you should be good to go.

    Regards,
    G.Smith



  • @herf hi! i´ve installed f.lux in my notebook and have a external monitor (HDMI) plugged in, but i´ve observed that only the external monitor is working with f.lux. So, how can I use f.lux in both monitors?



  • Sorry to be a necromancer but this issue has just recently appeared for me and it is quite terrible. I run two monitors over the same graphics card, the main one being HDMI, the other VGA, and f.lux has worked for years on this setup without a single hickup. Only the windows update from a few weeks ago, known in my house as "the one that bricked literally everything," destroyed this. Now the VGA monitor does not dim, and it is severely affecting my sleep cycle as I often have to work late into the night. I have installed the latest graphics card drivers, uninstalled and re-installed f.lux (which somehow reset my dark mode settings in Windows), run it in administrator mode, to find the issue, but I have come up dry.
    The curious thing is that greyscale mode, from the effects tab, works on both monitors just fine. It is the only thing that does this, and I have no idea why. Also, when I turn it to the lowest setting (Ember), my main monitor dims, but the secondary monitor becomes greyscale.
    Again, my setup has worked fine for years, and in the process of testing I have also found that Windows' own Night Light mode also only works on my main monitor, not the secondary one.
    As for technical specifications:
    My graphics card is an AMD Radeon R9 200 Series
    The HDMI monitor (the one that works) is a LG IPS Monitor MP55
    The VGA monitor (the one that doesn't work) is an AOC LCD monitor I don't know the name of because it doesn't say.

    I'd really appreciate some guidance here as f.lux has tremendously increased my quality of life and now I can't use it anymore.


Log in to reply