MacOS Catalina Bug



  • Flux doesn't seem to work on latest Catalina OS. After turning it on, it flashes and colors/temp looks weird.


  • f.lux team

    Which hardware are you using?
    Also do you have access to the Feedback Assistant (beta or developer)?



  • The same problem.
    MacBook Pro (15-inch, 2018)


  • f.lux team

    Anyone reading this: if you have Feedback Assistant, please send a report to Apple (we can't report it otherwise).

    For general troubleshooting:

    1. Try disabling automatic brightness - does it help?
    2. Try disabling automatic GPU switching if you have two GPUs


  • Can confirm - I have the same problem. (Macbook Pro 13 inch, 2018).

    This device does not feature a second GPU.
    Disabling automatic brightness does not fix the behavior (looks the same).



  • @testesttest8889 I confirm, Flux doesn't work correctly on my MacBook Pro 13-inch 2019 with Catalina OS. It flash and look very weird... Closing flux and everything return to normal...


  • f.lux team

    Can someone also test turning off True Tone? A conflict there would make sense, since it's only on the newer models.



  • 2018 MacBook Pro 13-inch with Catalina OS and True Tone off still causes the flashing and colors/temp to look off



  • Yep, True Tone is disabled.



  • Same issue here. Flux also causes OSX to prompt to grant screen recording permissions. I suspect the latter is just due to the API it uses, but perhaps failing to grant it is what's causing the problem?


  • f.lux team

    This should only be in the about box, which we use to estimate screen brightness. Could add a button you'd have to push if it's too alarming.



  • F.lux didn't work for me either when I installed Catalina, but when I ticked "true tone" box it started working normally again.


  • f.lux team

    Anyone with "Feedback Assistant" please send a note to Apple for us?

    Has to be done on a machine that's affected, and we haven't bought a new MBP yet. :)



  • Just a small report from me - everything works now. I haven't changed anything nor updated something, yet it started to work normally again. Maybe this is only in the first few hours after upgrading?


  • f.lux team

    @_paul Okay so maybe this is a True tone conflict, it just takes some time to actually turn off?



  • Still experiencing same problem, turning of True Tone/Auto Brightness didn't help



  • For me it works when my external display is plugged in. As soon as I unplug it everything starts flickering and the color filter is only showing around the UI elements, on and off.

    As other mentioned, True tone and auto brightness don't change a thing.



  • Just for the record, I highly doubt this issue is related to f.lux. As far as I can tell, f.lux is simply feeding a color profile to macOS, and there seems to be a general color profile issue going on in Catalina.

    I have custom monitor calibration profiles (from a calibration device), and macOS randomly ignored the profile. As far as I can tell, most of the time, macOS decides to apply the color profile correctly for everything except for pure white. #fff is always rendered as #fff, even though the color profile might tint it differently. In f.lux, this is especially harsh since everything white will glow really bright next to the red'ish colors.

    I have reported several issues in regards to color profiles in Catalina via the Feedback Assistant.



  • Same issue on MBP 15,4. Haven't yet noticed the problem on iMac 18,3 with additional external display.

    For what it's worth, a system restart fixes this bug for me, at least until a subsequent sleep/wake cycle. (Merely restarting f.lux does not fix the bug, though obviously the flashing effect ceases when f.lux is disabled.)



  • In case it helps this is happening on my macbook pro since installing Catalina. It also happens with another similar app called Iris.



  • Have true tone disabled, have night shift disabled, and no external monitor. With flux running the screen flickers and changes color on a regular/random basis.

    Have the issue with both stock and custom profiles. It's definitely a flux/catalina incompatibility. Now, on who's end I can't say :-).



  • any update on whether this will be fixed?


  • f.lux team

    @bnodvin we do not have a workaround.

    As above, anyone with "Feedback Assistant" please send a note to Apple for us?



  • And it's back again after installing the latest update. :-(

    herf: Any way to get that feedback app without being a developer?



  • I'm seeing this issue as well. In case it's helpful, here's a short (1 min.) video to give you an idea what's happening. As you can see onscreen in the video, both True Tone and automatic brightness are already disabled.

    https://imgur.com/a/EMWNknw


  • f.lux team

    Two things:

    1. How many of you have a dual-GPU mac, vs. integrated only?
    2. Does it help (in either case) to enable writeProfile using these instructions?
      https://justgetflux.com/news/2014/10/28/profile.html

    defaults write org.herf.Flux writeProfile 1

    If this is happening mostly on discrete GPU macs, it's possible that the new security parameters in Catalina are preventing f.lux from noticing it's a dual GPU machine (which I had not considered before).



  • @_paul said in MacOS Catalina Bug:

    And it's back again after installing the latest update. :-(

    herf: Any way to get that feedback app without being a developer?

    OK: Turns out this is really wierd. It's back to working again. I have not changed a thing, have not rebooted or something, it just works. The same as last time - Wait a few days, and it'll sort it out by itself. Guess I better not reboot anytime soon, haha.



  • I am also experienced this issue after upgrading to Catalina on my 2019 MBP (13 inch).

    It appears to blink within Firefox only, although, the color/temp is messed up across all apps.

    It's only being experienced when no external monitors are connected. Issue is not present with an external monitor connected.

    @herf said in MacOS Catalina Bug:
    Two things:

    1. How many of you have a dual-GPU mac, vs. integrated only?
    2. Does it help (in either case) to enable writeProfile using these instructions?
      https://justgetflux.com/news/2014/10/28/profile.html

    defaults write org.herf.Flux writeProfile 1

    If this is happening mostly on discrete GPU macs, it's possible that the new security parameters in Catalina are preventing f.lux from noticing it's a dual GPU machine (which I had not considered before).

    1. Integrated only
    2. This did not help, unfortunately.

    If I can provide any additional information, please let me know.



  • Truetone have been causing problems with flux for the last year, but after MacOS Catalina it is impossible, is flashing with every single white colour in the screen, this is the first time in 10 years that my only option is disabling flux



  • In case this helps anyone, I was having issues on a 2018 MBP w/ integrated graphics, however enabling True Tone seems to have fixed the issues I was having. I think I had to disable true tone in the last release, lol.

    I also have night shift disabled.



  • It appears that this is fixed in the current Catalina beta. Although there is now another issue (the mouse cursor is not affected by any color profile, what fun.) color profiles itself now stick, and flux is no longer having weird issues.



  • Update: Issue is no longer present on my end after latest Catalina update; 10.15.1



  • @denschub said in MacOS Catalina Bug:

    It appears that this is fixed in the current Catalina beta. Although there is now another issue (the mouse cursor is not affected by any color profile, what fun.) color profiles itself now stick, and flux is no longer having weird issues.

    I am also seeing a blue cursor on 10.15.1.



  • The flashing is no longer happening as of 10.15.1, but now I'm seeing a new issue. With True Tone on, enabling Movie Mode drops the screen to the deepest, late-night amber color rather than lightening it up — ie. it does the opposite of what Movie Mode is supposed to. The blue cursor others have mentioned appears when this happens as well.

    With True Tone off on the other hand, Movie Mode works normally. I guess I can toggle True Tone off at the same time I turn Movie Mode on, but I quite like the effect of True Tone overall, and it doesn't currently seem to cause issues with Flux otherwise.



  • I can also add that Flux is all jacked up on my 2018 MacBook Pro. It turns really dark red late at night and I have to disable it for an hour to make my computer usable. I'm on 10.15.1 as well.



  • Mac OS Catalina. Macbook Pro 2019. I have the same problem. Flashing tints and colors.
    This happened only after installing Catalina.
    I do not have access to Feedback Assistant.
    It was stable for a few days with True Tone turned on – everything seemed to work normally.
    Then it started flashing again, cursor is day white (with true tone on or off) while everything else is evening-toned.
    Then switching to movie mode makes grays go black, with true tone on.
    Turning true tone off makes black go away, cursor is still day white.
    Overall still buggy, can't find a combinations of settings to make things stable. I have to quit and instead use apple's night shift.



  • I should say instead of simply Catalina, OSX 10.5.1 to be more precise


  • f.lux team


  • f.lux team

    Okay try again with 39.9873?

    Link is here:
    https://forum.justgetflux.com/topic/7248/mac-beta